Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Проставить порядковые номера строк по условиям
 
Очень много тем с порядковыми номерами или счетчиками, но они все с оригинальными условиями, поэтому решил написать. Таблица 2 столбца с данными А и B, колонка индикатор условия ЕСЛИ(B3=0;ЕСЛИ(A3>0;1;"");"") и последняя колонка порядковый номер строки с положительным индикатором. Во вложении как должно быть. Если можно все в дну формулу я не против. Извините если решение очень легкое.
 
Код
=ЕСЛИ(B2=0;ЕСЛИ(A2>0;МАКС(C$1:C1)+1;"");"")
или
=ЕСЛИ(И(B2=0;A2>0);МАКС(C$1:C1)+1;"")
 
Цитата
Казанский написал:
=ЕСЛИ(B2=0;ЕСЛИ(A2>0;МАКС(C$1:C1)+1;"");"")
Спасибо! Работает.
Страницы: 1
Читают тему (гостей: 1)