Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Автоматически присвоить группы
 
Добрый день! Вышла из декрета и поняла, что он прошел успешно, хоть убей не помню как обрабатывала базы. Очень прошу помочь  :oops:

Суть проблемы.
Есть список медицинских организаций в формате, указанном ниже. В соседнем столбце мне нужно присвоить каждой ячейке специализацию (напр., многопрофильное учреждение, стоматология, травматолоия и ортопедия, акушерство и гинекология и пр.). Как бы мне логично выстроить сложный IF?


ГОСУДАРСТВЕННОЕ БЮДЖЕТНОЕ УЧРЕЖДЕНИЕ ЗДРАВООХРАНЕНИЯ "СРЕДНЕАХТУБИНСКАЯ ЦЕНТРАЛЬНАЯ РАЙОННАЯ БОЛЬНИЦА"
ГОСУДАРСТВЕННОЕ БЮДЖЕТНОЕ УЧРЕЖДЕНИЕ ЗДРАВООХРАНЕНИЯ "СТАРОПОЛТАВСКАЯ ЦЕНТРАЛЬНАЯ РАЙОННАЯ БОЛЬНИЦА"
ГОСУДАРСТВЕННОЕ БЮДЖЕТНОЕ УЧРЕЖДЕНИЕ ЗДРАВООХРАНЕНИЯ "ЦЕНТРАЛЬНАЯ РАЙОННАЯ БОЛЬНИЦА СУРОВИКИНСКОГО МУНИЦИПАЛЬНОГО РАЙОНА", ВОЛГОГРАДСКАЯ ОБЛАСТЬ, ГОРОД СУРОВИКИНО
ГОСУДАРСТВЕННОЕ АВТОНОМНОЕ УЧРЕЖДЕНИЕ ЗДРАВООХРАНЕНИЯ "СТОМАТОЛОГИЧЕСКАЯ ПОЛИКЛИНИКА СУРОВИКИНСКОГО МУНИЦИПАЛЬНОГО РАЙОНА" ВОЛГОГРАДСКАЯ ОБЛАСТЬ, ГОРОД СУРОВИКИНО
ГОСУДАРСТВЕННОЕ БЮДЖЕТНОЕ УЧРЕЖДЕНИЕ ЗДРАВООХРАНЕНИЯ УРЮПИНСКАЯ ЦЕНТРАЛЬНАЯ РАЙОННАЯ БОЛЬНИЦА ИМЕНИ В.Ф. ЖОГОВА
ЗАКРЫТОЕ АКЦИОНЕРНОЕ ОБЩЕСТВО "СТОМАТОЛОГ"
ГОСУДАРСТВЕННОЕ БЮДЖЕТНОЕ УЧРЕЖДЕНИЕ ЗДРАВООХРАНЕНИЯ "ФРОЛОВСКАЯ ЦЕНТРАЛЬНАЯ РАЙОННАЯ БОЛЬНИЦА"
ГОСУДАРСТВЕННОЕ БЮДЖЕТНОЕ УЧРЕЖДЕНИЕ ЗДРАВООХРАНЕНИЯ ЧЕРНЫШКОВСКАЯ ЦЕНТРАЛЬНАЯ РАЙОННАЯ БОЛЬНИЦА
ФЕДЕРАЛЬНОЕ КАЗЕННОЕ УЧРЕЖДЕНИЕ ЗДРАВООХРАНЕНИЯ "МЕДИКО-САНИТАРНАЯ ЧАСТЬ МИНИСТЕРСТВА ВНУТРЕННИХ ДЕЛ РОССИЙСКОЙ ФЕДЕРАЦИИ ПО ВОЛГОГРАДСКОЙ ОБЛАСТИ"
ОБЩЕСТВО С ОГРАНИЧЕННОЙ ОТВЕТСТВЕННОСТЬЮ "РУСАЛ МЕДИЦИНСКИЙ ЦЕНТР"
ОБЩЕСТВО С ОГРАНИЧЕННОЙ ОТВЕТСТВЕННОСТЬЮ "СТОМА-ВИД"
ОБЩЕСТВО С ОГРАНИЧЕННОЙ ОТВЕТСТВЕННОСТЬЮ "СТОМАТОЛОГИЧЕСКАЯ ПОЛИКЛИНИКА "ЛАЗУРЬ-ЭЛИТ"
ОБЩЕСТВО С ОГРАНИЧЕННОЙ ОТВЕТСТВЕННОСТЬЮ "ЕВРОПАДЕНТ"
 
создаете список учреждений напротив каждого проставляете специализацию а потом в нужном документе тянете через ВПР
Лень двигатель прогресса, доказано!!!
 
Как вариант понимаю, что можно каждой группе присвоить столбец-специализацию и составить фильтр из серии "Если в А1:А5800 (список строк базы) есть "стоматологическая", то 1. И так по 34 специализациям. Это наверное проще. Но как написать это условие  :(  
 
Цитата
Сергей написал:
создаете список учреждений напротив каждого проставляете специализацию а потом в нужном документе тянете через ВПР
Да, я так и делала.

=ВПР("роддом";$A$2:$B$5800;1;2). но выдает значения "ДАРСТВ" во всех строках =(
 
Цитата
Kolibrita написал:
=ВПР("роддом";$A$2:$B$5800;1;2)
Что такое 2?
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
 
Цитата
Bema написал:
Что такое 2?
Пардон, там 1
 
Kolibrita, Вы бы лучше небольшой пример показали.
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
 
Цитата
Kolibrita написал:
Пардон, там 1
а надо 0, а вот перед ним 2. =ВПР("роддом";$A$2:$B$5800;2;0)
 
Цитата
Bema написал:
Вы бы лучше небольшой пример показали.

Как-то так
 
хм
 
ВПР Вы применяете неверно. Формула массива:
=ЕСЛИ(ИЛИ(ЕЧИСЛО(ПОИСК({"дент":"стоматологич"};$A2)));"Стоматология";"")
Сделал для Стоматология, остальное сами.  
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
 
Bema, спасибо большое!!!!  
Страницы: 1
Читают тему (гостей: 1)