Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Подсчет стоимости работы в зависимости от наименования, количества работ и коэффициента
 
Ребята, подскажите плиз, как перемножить и вывести значение при нескольких условиях.
Вот эта формула =ЕСЛИ(ИЛИ(D4="";E4="");ВПР(B4;Таблица1[[Наименование работ]:[Стоимость]];2;ЛОЖЬ);ВПР(B4;Таблица1[[Наименование работ]:[Стоимость]];2;ЛОЖЬ)*D4*E4) работает, только, если обе ячейки заполнены, если же одна из ячеек пустая, формула не считает значение. Загадка где-то близко, запуталась с условиями, по идее их должно быть четыре (D заполненная E заполненная, D заполненная E пустая, D пустая E заполненная, D пустая E пустая. Но как их совместить? Я вобще в правильном направлении мыслю, или есть вариант полегче это всё запилить?
Заранее спасибо!
 
и что у вас не считает? в файле формула отработала.
 
V, не считает значение в ячейке С6, перемножения не происходит, т.к. ячейка E6 пустая.
 
Тему можно назвать: "Подсчет стоимости работы в зависимости от наименования , наличия количества работ и указанного коэффициента"
Изменено: a.i.mershik - 29 Мар 2018 14:21:56
 
a.i.mershik, да, Ради Бога ))) только задачу помогите решить, пожалуйста)
 
Katya1212, ну такая реакция у Вас не красиво - Вам делают замечания  будьте добры прислушиваться, так как вы за помощью пришли а не к вам пришил.

файл открывали?*
Изменено: a.i.mershik - 29 Мар 2018 14:28:13
 
a.i.mershik, Да открывала)), спасибо за помощь, но немножко не то.
Если обе ячейки пустые, то должно выводиться значение с листа "Данные", а сейчас пишется "0", см. вложение в ячейке C3/
 
Katya1212,
 
a.i.mershik, То, что надо ! Благодарю  :*  
Страницы: 1
Читают тему (гостей: 1)