Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Среднее по 3-м максимальным значениям, Надо выводить Среднее по 3-м максимальным значениям в зависимости от даты, разбитой на г/м/д.
 
Наверное мне нужно использовать функцию СРЗНАЧЕСЛИМН. Не получается. Или СРЗНАЧ с разными условиями. Помогите, кому интересно.
 
Наталья, а где дата?!
 
формула массива
=СРЗНАЧ(НАИБОЛЬШИЙ(ЕСЛИ((A$3:A$12=A19)*(B$3:B$12=B19)*(C$3:C$12=C19);D$3:D$12);{1:2:3}))
 
дата отдельными столбцами:г, м, д.  
 
Попробуйте еще такую формулу:
Код
=СУММПРОИЗВ((($C$3:$C$12)=5)*($D$3:$D$12))/СУММПРОИЗВ((($C$3:$C$12)=5)*1)
Понял, что мое решение не годится - поэтому предлагаю другое:
Код
=СУММПРОИЗВ((($D$7:$D$12)>=НАИБОЛЬШИЙ($D$7:$D$12;3))*($D$7:$D$12))/3
которое применимо при условии предварительной сортировки таблицы по датам
Изменено: IKor - 29 Мар 2018 16:40:20
 
Спасибо, получилось :)
 
Можно вашу чуть рихтануть
 
Добавить столбец с датой.
=СРЗНАЧ(НАИБОЛЬШИЙ(ЕСЛИ($E$3:$E$12=E12;$D$3:$D$12);{1;2;3}))
Формула массива
 
да, тоже можно использовать. интересно. спасибо )
 
Если для Excel2010+, то можно так
Код
=AVERAGE(AGGREGATE(14;6;D$3:D$1600/(A$3:A$1600=H3)/(B$3:B$1600=I3)/(C$3:C$1600=J3);{1;2;3}))
Страницы: 1
Читают тему (гостей: 1)