Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Удаление одинаковых значений из суммы диапозона
 
Здравствуйте, уважаемые Гуру!

Столкнулся с такой задачей:

Есть таблица
А
Б
1 ааа 1
2 ббб 1
3 ааа 1
4 ггг 1
5 ааа 1
6 Итого 3
Задача итоговой ячейки Б6 определить сумму диапазона Б1:Б5 с исключением повторных значений из диапазона А1:А5
Изменено: Александр22 - 30 Мар 2018 11:02:13
 
Формула массива:
=СУММ(ЕСЛИ(ПОИСКПОЗ(A1:A5;A1:A5;0)=СТРОКА(A1:A5);B1:B5))
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
 
Попробовал, не выходит.
 
Александр22, а если в Б не единицы будут какое значение для суммирования учитывать?
 
В столбце Б может быть любое целое значение.
 
Цитата
Александр22 написал:
Попробовал, не выходит.
формулу от Bema надо вводить через ctrl+shift+enter - она же массивная
 
Что-то не получается.
 
Получилось!!!
Спасибо!!!
 
В первой таблице без смещения, во второй со смещением
 
Все хорошо считает, но если очистить хотя бы одну ячейка из столбца А, то формула не работает.
 
Цитата
StepanWolkoff написал:
В первой таблице без смещения, во второй со смещением

Прикрепленные файлы
Пример (20).xlsx  (15.7 КБ)
Вариант со смещением мне и нужен. Но как быть с пустыми ячейками?
 
Александр22, Вы сейчас к кому обращаетесь?
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
 
Александр22, добавить проверку на пустые значения, только откуда они там берутся?
 
ОГРОМНОЕ спасибо!!!! Вы меня спасли!!!
Страницы: 1
Читают тему (гостей: 1)
Наверх