Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Выставить значение по условию с соседней ячейке
 
Добрый день

В ячейке А1 у меня может быть четыре значения.
HighMiddleLowNone
В ячейке B1 должно автоматически ставится цифра в зависимости от значения в Ячейке А1
HighMiddleLowNone
10005002500
Например:
АВ
1High1000
2Middle500
3High1000
4High1000
5Low250
6None0
Вопрос:  какая формула должна быть в ячейке b1,b2 и т.д.
 
=ПРОСМОТР(2;1/(A1={"None";"Low";"Middle";"High"});{0;250;500;1000})
=ВПР(A1;{"None";0:"Low";250:"Middle";500:"High";1000};2;)
 
Или так
Код
=ЕСЛИ(A3="high";1000;ЕСЛИ(A3="middle";500;ЕСЛИ(A3="low";250;ЕСЛИ(A3="none";0;""))))
Изменено: Dyroff - 2 Апр 2018 18:27:37
Нужно бежать со всех ног, чтобы только оставаться на месте, а чтобы куда-то попасть, надо бежать как минимум вдвое быстрее!
 
vikttur, А разделитель столбца точно там где стоит должен быть?   У меня как-то так
=VLOOKUP(B3;{"None"\0;"Low"\250;"Middle"\500;"High"\1000};2;)
ну и если не лень сортировать то
=LOOKUP(B3;{"High";"Low";"Middle";"None"};{1000;250;500;0})
Изменено: БМВ - 2 Апр 2018 19:39:05
 
vikttur, Dyroff, БМВ, Спасибо!
 
Цитата
БМВ написал: разделитель столбца точно там где стоит должен быть?
Да, прописка проверена, ошибок нет.
Еще одна:
=ИНДЕКС({0;250;500;1000};ПОИСКПОЗ(A1;{"None";"Low";"Middle";"High"};))
Страницы: 1
Читают тему (гостей: 1)
Наверх