Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Сумма произведений с выбором диапазона
 
Добрый вечер,
Подскажите пожалуйста, как можно сделать сумму произведений диапазонов ячеек с выбором одного из диапазона по известному критерию?
Думаю что можно использовать SUMPRODUCT, но никак не придумаю, как можно выбрать диапазон, на который нужно умножить, если их некоторое количество.
В примере, в зависимости от "Критерия" (колонка "H") нужно выбрать соответствующий диапазон из C2:C4 по значению H8:H11 и сложить произведения по принципу SUMPRODUCT пофамильно.
Поиск такого не выдает или я неверно формулирую запрос (((
 
Если правильно поняла
Код
=СУММПРОИЗВ(D8:G8;ИНДЕКС($D$2:$G$4;ПОИСКПОЗ($H8;$C$2:$C$4;0);0))
 
Pelena,
Спасибо Вам большое, то что нужно  :)  
Страницы: 1
Читают тему (гостей: 1)
Наверх