Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Таблица со средним значением по дням недели, Получить в таблице/диаграмме данные по среднему значению по дням недели
 
Всем добрый день!

во вложении таблица, Я хочу получить средние данные по дням недели за весь период наблюдений.

помогите, пожалуйста!

спасибо!
Just keep doing!..
 
Как то так
Код
=СУММПРОИЗВ((ДЕНЬНЕД(Sheet1!$B$3:$Y$3;2)=A4)*(Sheet1!$B$4:$Y$4))/СУММПРОИЗВ((ДЕНЬНЕД(Sheet1!$B$3:$Y$3;2)=A4)*1)

нужный диапазон сами задайте
 
Код
=СУММПРОИЗВ(R4C23:R4C74*(ДЕНЬНЕД(R3C23:R3C74)=ДЕНЬНЕД(RC[-1])))/СУММПРОИЗВ(НЕ(ЕПУСТО(R4C23:R4C74))*(ДЕНЬНЕД(R3C23:R3C74)=ДЕНЬНЕД(RC[-1])))
Программисты - это люди, решающие проблемы, о существовании которых Вы не подозревали, методами, которых Вы не понимаете!
 
Однако ленивый вариант - сводная диаграмма с группировкой по плоской таблице, имхо - самое то... ;)
Изменено: Z - 3 Апр 2018 15:01:04
"Ctrl+S" - достойное завершение ваших гениальных мыслей!.. ;)
 
всем большое спасибо за участие!
Just keep doing!..
Страницы: 1
Читают тему (гостей: 1)