Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Сравнение двух таблиц с помощью условного форматирования, Сравнение двух таблиц с помощью условного форматирования при множестве условий для сопоставления
 
Здравствуйте

Прошу помощи в решении следующего вопроса:
Два отдела предоставляют списки накладных. Второй список надо проконтролировать относительно первого т.е. все накладные из второй таблицы обязательно должны быть отражены и в первом списке. Сравнение должно идти одновременно по 4 условиям: дата, номер, сумма и контрагент. В результате сравнения накладная, второй таблицы (в файле она справа), которая не имеет дубля в первой таблице должна быть каким-то образом выделена (я думала, через условное форматирование цветом, но можно и иначе).

Заранее благодарю  :)  
 
В ячейку L2 и тяните вниз
=ЕСЛИ(СУММПРОИЗВ(($A$2:$A$376=G2)*($B$2:$B$376=H2)*($C$2:$C$376=I2)*($D$2:$D$376=J2))=1;"Есть";"Нет")
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
 
Здравствуйте. Можно как предложил ув.Bema (это будет проще).
А можно, как Вы хотели, через УФ с доп.столбцом. Сначала в  М2 вводим формулу массива и растягиваем ее по границе 2-й таблицы.
Скрытый текст
, потом выделяем вторую таблицу (всю) и рисуем правило УФ через формулу. Формула такая:
Скрытый текст
ставим нужную заливку.
Вспомогательный столбец М можно коварно скрыть.
Изменено: Пытливый - 3 Апр 2018 17:08:38
Кому решение нужно - тот пример и рисует.
 
ОООООООГРОМНОЕ СПАСИБО!  :)  
Страницы: 1
Читают тему (гостей: 1)