Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Как научить поискпоз искать по дате, представленной в виде формулы
 
Добрый день! Прошу помощи.

Исходные данные:

1) Таблица 1 содержит данные для таблицы 2 (перечень товаров, даты закупки, объем закупки - массив данных).
2) Данные вытягиваются комбинацией ИНДЕКС+ПОИСКПОЗ
3) В таблице 1 строка с датами содержит собственно сами даты в формате ДД.ММ.ГГГГ
4) В таблице 2 строка с датами содержит ссылку на другой лист (исправить нет возможности - не редактируемые поля финансовой модели) "=Параметры!A10"

Проблема:

Функция ПОИСКПОЗ не сопоставляет дату в таблице 1 и дату в таблице 2, выдает ошибку.

Вопрос: есть ль возможность подружить ПОИСКПОЗ и дату в формате ссылки?
Изменено: Mortem - 3 Апр 2018 17:32:14
 
Цитата
Mortem написал:
ПОИСКПОЗ не сопоставляет дату в таблице 1 и дату в таблице 2, выдает ошибку
Какую ошибку? Если это НД - значит даты такой точно нет. Либо ищете дату, а в другой таблице это не дата, а текст, или наоборот.
Без примера данных только догадки могут быть.
Даже самый простой вопрос можно превратить в огромную проблему. Достаточно не уметь формулировать вопросы...
 
Mortem, приложите файл пример.
 
Цитата
Дмитрий Щербаков написал:
Какую ошибку? Если это НД - значит даты такой точно нет.
Да, ошибка НД.
Искомая дата "сен.20" отображается в обеих таблицах одинаково, но

- В таблице 1 ячейка содержит собственно дату "01.09.2020"

- В таблице 2 ячейка содержит формулу "=ЕСЛИ(AE32; ТЕКСТ(AE29;"#") & "-" & ТЕКСТ(МЕСЯЦ(AE27);"#") & "." & ТЕКСТ(AE28;"#"); ВЫБОР(Prj_Period; СМЕЩ(Language!$A63;AE29-1;0) & "." & ТЕКСТ(AE28-2000;"#"); ТЕКСТ(ОКРУГЛВВЕРХ(AE29/3;0);"#") & " " & Language!$A47 & " " & ТЕКСТ(AE28;"#"); ТЕКСТ(AE28;"#")))"
 
a.i.mershik, пример приложить не могу к сожалению. Спасибо за попытку помочь.
 
Цитата
Mortem написал:
В таблице 2 ячейка содержит формулу
судя по формуле - возвращаемое значение текст чистой воды. Без файла примера сложно тут что-то более вменяемое рекомендовать, кроме как искать тоже текст:
=ПОИСКПОЗ(ТЕКСТ(ячейка с датой;"МММ.ДД");где ищем;0)
но еще надо учитывать - год-то хоть совпадает?
Даже самый простой вопрос можно превратить в огромную проблему. Достаточно не уметь формулировать вопросы...
 
Mortem,  В таблице 2 ячейка содержит формулу , которая благополучно выдаст текст, а надо значение даты. или преобразовывайте перед поиском или .....

Дмитрий Щербаков, ой мы с огнем играем ибо название  темы , ну никак не в тему.
Изменено: БМВ - 3 Апр 2018 18:05:07
 
БМВ, Дмитрий Щербаков,

Спасибо за ценные мысли и советы!
Поскольку в искомой таблице даты в формате дат, а в таблице для подстановки даты в текстовом формате - помогло преобразование искомого параметра:
=ПОИСКПОЗ(ДАТАЗНАЧ(ячейка с датой);где ищем;0)


p.s. в очередной раз восхищаюсь форумом и его завсегдатаями
Страницы: 1
Читают тему (гостей: 1)