Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
При вводе начала и конца отрезка закрашивать временные отрезки на шкале времени
 
поискал на форуме по ключевым словам "Отрезки дат" безрезультатно. Подскажите, как сделать, чтобы при вводе начала и конца отрезка закрашивались временные отрезки на шкале времени?
 
Сергей Ким, через УФ
 
Ух ты, мгновенный ответ, а ка увидеть алгоритм?
 
назовем РЯ - рассматриваемая ячейка
тогда алгоритм коротко такой:
если дата в строке 1 колонки РЯ  >= даты в 3-й колонке строки РЯ и одновременно <= даты в 4-й колонке строки РЯ, то РЯ нужно залить желтым цветом
Программисты - это люди, решающие проблемы, о существовании которых Вы не подозревали, методами, которых Вы не понимаете!
 
не можете продемонстрировать внутри файла, хочу увидеть формулы, а то в ответе a.i.mershik не вижу никаких формул, но закрашивание яччек работает при изменении даты, обращаюсь и к вам, Ігор Гончаренко, и к a.i.mershik, и кто может показать мне формулы
 
Сергей Ким, а в "Приемы" заглядывали? Эта статья не поможет?
 
Цитата
Сергей Ким написал:
в ответе  a.i.mershik  не вижу никаких формул
Есть там формулы. Ищите их в правилах Условного форматирования.
 
Цитата
Юрий М написал:
в "Приемы" заглядывали?
Спасибо за указание, что-то подобное искал, но не знал где )) Буду изучать
 
1. отметьте одну из ячеек закрашиваемой области
2. нажмите кнопку "условное форматирование" (на ленте Главная в группе Стили)
формула там
удачи!
Программисты - это люди, решающие проблемы, о существовании которых Вы не подозревали, методами, которых Вы не понимаете!
 
Гуру Экселя, подскажите как выделить временной диапазон на таблице пересечения названия и дат с другого листа?  
 
Fonbrenberg,
=(C$1>=VLOOKUP($A2;скидка!$A:$D;3;0))=(C$1<=VLOOKUP($A2;скидка!$A:$D;4;0))

=(C$1>=ВПР($A2;скидка!$A:$D;3;0))=(C$1<=ВПР($A2;скидка!$A:$D;4;0))
 
именованный диапазон в УФ ( на примере яблока)
 
Offtop
Vik_tor, Файл называется скикидки _груши  -
Цитата
Vik_tor написал:
в УФ ( на примере яблока)
:-) забавно вышло.
Изменено: БМВ - 4 Апр 2018 13:59:43
 
Мичурин )
 
Цитата
БМВ написал:
=(C$1>=VLOOKUP($A2;скидка!$A:$D;3;0))=(C$1 =ВПР($A2;скидка!$A:$D;3;0))=(C$1<=ВПР($A2;скидка!$A:$D;4;0))
Цитата
Vik_tor написал:
именованный диапазон в УФ ( на примере яблока)
Спасибо огромное! Хорошего Вам дня!
Страницы: 1
Читают тему (гостей: 1)
Наверх