Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Автоматическая нумерация ФИО в таблице
 
Всем доброго времени суток. Если таблица Эксель, где по нумерации расположены имена и фамилии. В процессе работы из списка приходится исключать некоторых людей и нумерация сбивается, есть ли такая возможность сделать автоматическую нумерацию, чтобы при удалении, нумерация сохранялась в правильной последовательности как в ворде. Заранее спасибо.  
 
ячейка А1 = 1
ячейка А2 = COUNT($A$1:A1)+1, или MAX($A$1:A1)+1
и тяните вниз
count лучше, считает, даже если первого в списке удалить
Изменено: yozhik - 4 Апр 2018 17:21:18
 
Спасибо, помогло. А есть возможность чтобы при удалении строки, строка которая ниже возвратилась на место удаленной. Например, нумерация с 1 до 10, я удаляю 5 строку (в итоге строка остаётся пустой) а надо чтобы 6 строка встала на место 5ой?
 
=ЕСЛИ(СТРОКА()=1;1;МАКС(ИНДЕКС(A:A;1):ИНДЕКС(A:A;СТРОКА()-1))+1)
Страницы: 1
Читают тему (гостей: 1)