Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Сколько месяцев до даты
 
Как должна быть написана формула чтобы в столбце "Период образования" автоматически писалось - Например "Свыше 24 мес" или "от 12 до 24 мес". Я писала вручную, а как сделать чтобы писалось формулой? Если принять что декабрь 17 это до 1 мес. (у меня не правильно там написано. поскольку я считала в расчете на сегодняшний день.
 
Можна бы так написать:
Если в 'A2' находится дата "01-01-2016", а в "B2" находится дата "04-04-2018", то в "С2" формула (но я не знаю русского названия этой функции):
Код
=(DATEDIF(A2,B2,"y")*12) + DATEDIF(A2,B2,"ym") & " mesyatsev"

"y" - лета/годы
"ym" - месяцы
"md" - дни

Теперь некоторые условия "Если", и имеем диапазоны отдельных месяцев, меньше, выше, и так далее.
Вам нужно только изменить формат даты в столбце "D".

Смотрите тоже здесь:
https://support.office.com/en-us/article/datedif-function-25dba1a4-2812-480b-84dd-8b32a451b35c
 
В "Приемах" есть статья на эту тему.    
 
ocet p, Юрий М, Спасибо, с этим разобралась. А как условия с "если" будут выглядить примерно?
 
в вашем примере дат нет
Лень двигатель прогресса, доказано!!!
 
Сергей,Я уже сделала получилось вот так)
 
если ссылаетесь на конкретное число тогда уж так можно в Е2 и растянуть
Код
=ВПР(Таблица1[[#Эта строка];[01.12.2017]];{0;"до 1 мес":1;"от 1 до 2 мес":2;"от 2 до 3 мес":3;"от 3 до 4 мес":4;"от 4 до 5 мес":5;"от 5 до 6 мес":6;"от 6 до 7 мес":7;"от 7 до 8 мес":8;"от 8 до 9 мес":9;"от 9 до 10 мес":10;"от 10 до 11 мес":11;"от 11 до 12 мес":12;"от 12 до 24 мес":25;"Свыше 24 мес"};2;1)
Лень двигатель прогресса, доказано!!!
 
Сергей, Как она понимает что число свыше 25 нужно писать "свыше 24", я думала она будет только конкретно число 25 искать. А числа 26, 27, 28, игнорировать
 
если искомое число больше функция найдет ближайшее меньшее к данному числу то есть если вы укажете 1000 то для функции в просматриваемом диапазоне будет 25, так работать её заставляет последний параметр где мы указали 1, если бы там стоял 0 то функция бы искала точное совпадение и уже ни че го бы не нашла
Лень двигатель прогресса, доказано!!!
 
Сергей,Поняла, спасибо, так, конечно формула гораздо короче получается)
 
Цитата
Allablond написал:
формула гораздо короче получается
она будет еще короче если где то на листе хоть на другом сделать таблицу соответствий
0до 1 мес
1от 1 до 2 мес
2от 2 до 3 мес
3от 3 до 4 мес
4от 4 до 5 мес
5от 5 до 6 мес
6от 6 до 7 мес
7от 7 до 8 мес
8от 8 до 9 мес
9от 9 до 10 мес
10от 10 до 11 мес
11от 11 до 12 мес
12от 12 до 24 мес
Лень двигатель прогресса, доказано!!!
 
Allablond, у Вас установлены неверные интервалы времени.
Например, если, рассчитано ровно 5 месяцев, в каком диапазоне времени они должны включаться ?
"От 4 до 5 мес" или "От 5 до 6 мес" ?
Страницы: 1
Читают тему (гостей: 1)
Наверх