Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Выборка по столбцам: проставить фамилию и группу рядом с фамилией
 
Есть таблица с кучей столбцов с фамилиями, они в разных группах.
Нужна выборка что бы проставляло фамилию и группу рядом с фамилией, как сделать что то не могу сообразить.
Изменено: DukeEsaul - 4 Апр 2018 20:40:33
 
ну с названием темы скорее всего тоже надо будет вопрос решать, а пока, У вас наверно будет одна строка с данными? А количество групп ограничено? Могут быть теже в разных группах и строках. ....
 
количество групп, не более 6
фамилий куча

Список такого типа
Фамилия   "группа"
Руками очень долго.
 
Формула строго под Ваш пример:
=ИНДЕКС($1:$1;;(СТРОКА(1:1)-1)*2+1)
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
 
Спасибо строку проставляет идеально. А как сделать что бы она все столбцы проверяла. Фамилий в столбцах не по одной сотне.
 
Цитата
DukeEsaul написал:
Фамилий в столбцах не по одной сотне.
В примере только 4. Сделайте более реальный пример и покажите желаемый результат.
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
 
Первый лист список фамилий и группа, второй лист разбивка на группы, во втором листе в группах их около 2000 в общем. Все фамилии не стал копировать куча их. Это часть.
 
МАССИВНАЯ
=INDEX($A$1:$H$1; SMALL(IF($B$2:$H$7=J7;COLUMN($B$2:$H$7));1)-1)
 
Спасибо большое.
В пределах 6 строк все четко работает, а мне надо строк хотя бы на 600 работало. Буду разбираться.
 
Цитата
DukeEsaul написал:
на 600 работало
=INDEX($A$1:$H$1; SMALL(IF($B$2:$H$602=J7;COLUMN($B$1:$H$1));1)-1)
и во второй части можно так как указано тут
 
Выдает ошибку, и не работает вторая на все 600 строк.
 
DukeEsaul, Это формула массива,  CTRL+SHIFT+ENTER, а не просто ENTER
 
Не ну понятно что с контр шифт энтер вставлял, все равно в ячейке
#ИМЯ?
 
Ну так судя по всему вы прям вставляете что я в #10 показал. Тогда вам нужно установит Office Multi Language Pack, переключить интерфейс на ENG и вставить формулу.
Ну или не ленится а посмотреть что в файле #8 и подправить области, оставив русскоязычные функции.

Make your choose. :-)
 
Спасибо. Все заработало в том варианте что Вы дали. После этого всего начинаю, менять столбцы и прочие диапазоны.  На столбцах с А по Н работает переношу на другие, фигу..
 

Ну если с областью данных все просто, то  сложность у вас только с тем что выделил

=INDEX($A$1:$H$1; SMALL(IF($B$2:$H$602=J7;COLUMN($B$1:$H$1));1)-1)

COLUMN($B$1:$H$1)); выдает номер столбца не относительно области, а относительно A , то есть 2,3,;... заголовок , из-за объединения лежит в столбцах 1,3,5 для этого -1 в формуле, но можно было .COLUMN($A$1:$G$1)); главное чтоб количество столбцов было равное тут и области данных. При смещении области данных на  скажем 3 столбца, и эту нужно сместить на три  

$A$1:$H$1 - в данном случае всегда с A . Также  можно записать это  $1:$1

Страницы: 1
Читают тему (гостей: 1)