Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Поиск параметра по категории товара
 
Всем доброго времини суток.Ни как не могу понять как сделать. Ситуация заключаться в следующем:

Есть два листа.На первом листе в столбике "A" показан  список товара. А в столбике "В" должна показываться категория к которой принадлежит сам товар.А условием служит таблица которая находиться на листе 2 и состоит из названия категории и параметра который нужно искать в тексте названия товара которому нужно присвоить в случаи совпадения категорию

То есть если в названии товара "3G WiFi роутер Huawei E5330" содержиться слово "3G WiFi" мы присваиваем ему категорию "Компьютерная техника".Знаю что для единичного случая можно воспользоваться ЕСЛИ в связке с СЧЁТЕСЛИ. Но таблица очень большая состоит из 50 категорий и каждая категория содержит порядка 70 возможных условий для поиска
Изменено: pasha2298 - 5 Апр 2018 16:25:09
 
pasha2298, файл пример приложите, где написано условие - и что проставить если выполняется это условие.
 
пример в файле поможет в разы быстрее вашей проблеме а так =ИНДЕКС(диапазон категорий:макс(ечисло(поиск(диапазон ключей;ссылка на ячейку))*строка(размер диапазона))) и все это массивным вводом
Лень двигатель прогресса, доказано!!!
 
Извините,уже приложил
Изменено: pasha2298 - 5 Апр 2018 14:36:55
 
Вчера была похожая тема. Формула массива. Вводить тремя клавишами Ctrl+Shift+Enter
=ИНДЕКС(Лист2!$A$1:$A$2;МИН(ЕСЛИ(ЕЧИСЛО(ПОИСК(Лист2!$B$1:$D$2;Лист1!A2));СТРОКА(Лист2!$A$1:$A$2))))
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
 
ну и вариант тогда
Лень двигатель прогресса, доказано!!!
 
pasha2298, И ВАРИАНТ ЕЩЕ..
Код
=ПРОСМОТР(2;1/(ПОИСК(Лист2!$B$1:$B$6;Лист1!A2));Лист2!$A$1:$A$6)
правда нужно данные из поиска чуть передалть к виду в файле...
 
Спасибо всем за помощь
Страницы: 1
Читают тему (гостей: 1)