Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Подобрать стоимость, соответствующую нескольким критериям
 
Добрый день!
Подскажите, пожалуйста, в таком вопросе:
Есть таблица со списками фигур по категории и по названию. Имеется разная стоимость в зависимости о выполняемой работы.
Теперь в другой таблице мне надо выбрать категорию фигуры, название фигуры, вид выполненной работы и в зависимости от этого должна подставляться стоимость, соответствующая этим критериям.
Собственно, списки я сделал. Смотрю в сторону в ИНДЕКС и ПОИСКПОЗ, но не пойму как всё соединить.
 
для "E2":
=ЕСЛИОШИБКА(СУММЕСЛИМН(ИНДЕКС(Лист1!C:E;0;ПОИСКПОЗ(D2;Лист1!$C$1:$E$1;0));Лист1!A:A;B2;Лист1!B:B;C2);"")
 
Спасибо большое!!!
Работает!!!!
 
Вариант с формулами
для одной операции
Код
=IFERROR(INDEX(Лист1!$C$2:$E$16;MATCH(1;INDEX((Лист1!A$2:A$16=B2)*(Лист1!B$2:B$16=C2);0);0);MATCH(D2;Лист1!C$1:E$1));"")
для общей суммы
Код
=IFERROR(SUM(INDEX(Лист1!$C$2:$E$16*(Лист1!A$2:A$16=B2)*(Лист1!B$2:B$16=C2);0));"")
Страницы: 1
Читают тему (гостей: 1)
Наверх