Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Заполнение новой таблицы данными по диагонали из имеющегося массива
 
Приветствую!
Прокопал форум - похожих задач не нашёл, потому, прошу подсказать, если кому не сложно.
Есть таблица (в примере - первая вкладка) из нескольких столбцов, данные по нескольким направлениям работы нескольких менеджеров и их результативность. Нужно преобразовать эту таблицу, когда имена менеджеров - столбец, направления - строка, баллы - по диагонали. Как перестроить столбец в строку - понятно, транспонированием, хотя, тут тоже вопрос: тупо значения вставить - это нормально работает, а вот можно ли вместо значений сделать привязку к базовой таблице, чтобы, при изменении её данных, менялось и в итоговой?

Основной вопрос: можно ли как-то сделать диагональный вывод данных из 4 колонки? В примере то, что должно получиться - во второй вкладке.

Версия Экселя 2013, вроде бы, СП1...Файл приложен для примера, в том, где надо это издевательство провернуть - несколько сотен строк, мне бы понять, как эту ересь делать...

Не нуб в Экселе, но, к таким задачам меня жизнь не готовила, буду рад помощи ;-)
 
формула массива
Код
=ЕСЛИ(СТОЛБЕЦ()=СТРОКА();ИНДЕКС(Исходное!$D$2:$D$12;ПОИСКПОЗ(1;(Исходное!$B$2:$B$12=B$1)*(Исходное!$A$2:$A$12=$A2);0));"")
Страницы: 1
Читают тему (гостей: 1)