Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Как объеденить два столбца в один, Из каждого столбца нужно брать по 4 строки
 
Добрый ночи!
вот тут обсуждали как перенести значения из нескольких столбцов в один, даже попарно.
А как сделать аналогичное в столбец d в порядке? надо по четыре строки.
a1,
а2,
a3,
а4,
b1,
b2,
b3,
b4,
a5,
...
Заранее признателен за любую помощь!
Изменено: sageskull - 9 Апр 2018 12:08:34
 
Да когда же Вы Правила начнёте читать, прежде чем вопрос задавать? Пункт 2.3 о чём говорит?
 
Извиняюсь, думал смогу просто объяснить. Добавил пример
Изменено: sageskull - 9 Апр 2018 12:08:13
 
Неужели никто не поможет?
 
Такую формулу проверьте:
=ИНДЕКС($A$1:$B$30;ОСТАТ(СТРОКА()-1;4)+1+ОТБР((СТРОКА()-1)/8;0)*4;--ЕЧЁТН(ОКРВВЕРХ(СТРОКА()/4;1))+1)
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
 
Тему можно назвать:
скопировать данные с одной таблицы в другую таблицу другой размерности
Код
=ИНДЕКС(A:B;ЦЕЛОЕ((СТРОКА()-1)/8)*4+ОСТАТ(СТРОКА()-1;4)+1;1+ОСТАТ(ЦЕЛОЕ((СТРОКА()-1)/4);2))
Программисты - это люди, решающие проблемы, о существовании которых Вы не подозревали, методами, которых Вы не понимаете!
 
Предлагаю ещё одно название для темы: Редизайнер. Трансформация. Изменение размерностей диапазона
«Тот, кто несет фонарь, спотыкается чаще, чем тот, кто идет следом.»
Иоганн Пауль Фридрих Рихтер
 
Цитата
Bema написал:
Такую формулу проверьте:=ИНДЕКС($A$1:$B$30;ОСТАТ(СТРОКА()-1;4)+1+ОТБР((СТРОКА()-1)/8;0)*4;--ЕЧЁТН(ОКРВВЕРХ(СТРОКА()/4;1))+1)
Проверил, отлично работает. Спасибо большое.
Цитата
Ігор Гончаренко написал:
1=ИНДЕКС(A:B;ЦЕЛОЕ((СТРОКА()-1)/8)*4+ОСТАТ(СТРОКА()-1;4)+1;1+ОСТАТ(ЦЕЛОЕ((СТРОКА()-1)/4);2))
Проверил, отлично работает. Спасибо большое.

Спасибо большое добрые люди! Обе формулы рабочие.
Страницы: 1
Читают тему (гостей: 1)
Наверх