Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Сложение чисел введенных через определенный символ
 
Ребята, снова нужна ваша помощь. Есть ячейки в которых числа введены через определенный символ, пусть это будет "/". Как можно сложить числа из двух ячеек чтобы результат получился тоже через этот символ? И к тому же в некоторых ячейках есть числа и без этого символа они тоже должны считаться корректно. Чтобы было более понятно прикладываю таблицу с примером.
Можно было бы разделить ячейку и потом сложить, но тогда получится несколько столбцов, что не совсем удобно. Пробовал с помощью такой конструкции реализовать
Код
ВПР(--ЛЕВБ(A2;НАЙТИ("/"...
но не могу довести ее до ума. Помогите, пожалуйста, разобраться с этой проблемой.
 
вариант
Код
=ЕСЛИ(ЕОШ(НАЙТИ("/";A2));A2+B2;ЛЕВБ(A2;НАЙТИ("/";A2)-1)+ЛЕВБ(B2;НАЙТИ("/";B2)-1)&"/"&ПРАВБ(A2;ДЛСТР(A2)-НАЙТИ("/";A2))+ПРАВБ(B2;ДЛСТР(B2)-НАЙТИ("/";B2)))
Лень двигатель прогресса, доказано!!!
 
Что-то не получается.
 
покажите
Лень двигатель прогресса, доказано!!!
 
Вот
 
правой кнопкой мыши => формат ячейки => общий => ок потом F2 затем энтер потом протянуть вниз затем начать радоваться от полученных знаний
Лень двигатель прогресса, доказано!!!
 
Большое спасибо, все заработало.
 
vladqw, а без цитирования никак? Запомните - кнопка цитирования не для ответа!
Страницы: 1
Читают тему (гостей: 1)
Наверх