Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Выпадающий список по нескольким параметрам (условиям).
 
Добрый день всем! Не могу сообразить как мне связать выпадающий список по нескольким параметрам (условиям). Пример прикрепил.
 
ozdjay, может это поможет https://www.planetaexcel.ru/techniques/1/38/
 
Не помогло. Тема актуальна
Изменено: ozdjay - 9 Апр 2018 15:14:35
 
ozdjay, странно или у Вас нельзя менять структуру таблицы?
 
В примере просто всего 2 условия для выпадающего списка, а у меня от 3х и более может быть, поэтому не понимаю как их связать.
Если Вы знаете как решить проблему, сделайте наглядно в Примере, который я скиул.
 
ozdjay, если быстро то с допстолбцом.
 
О, спасибо большое, это то, что надо!
 
ozdjay, ну и в сводной таблице гораздо проще как по мне.
Изменено: a.i.mershik - 9 Апр 2018 15:45:33
 
a.i.mershik, да, выглядит попроще. Но я уже заморочился без сводной таблицы.
Теперь другая проблема передо мной возникла, случилось так, что добавился еще один столбец, а кол-во параметров не изменилось. Можно ли как-нибудь сделать так, чтобы одинаковые названия исчезали? Пример прикрепил.
 
ozdjay, Добрый день, вроде так.
Код
=ЕСЛИОШИБКА(ИНДЕКС($E$4:$E$21;ПОИСКПОЗ(1;ИНДЕКС((СЧЁТЕСЛИ(O$1:O1;$E$4:$E$21)=0)/(($A$4:$A$21=$I$5)*($B$4:$B$21=$J$5)*($C$4:$C$21=$K$5));0);0));"")
 
a.i.mershik, спасибо огромное!!
Страницы: 1
Читают тему (гостей: 1)