Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Поиск и подстановка данных из одной таблицы в другую
 
Подскажите, как сделать такой поиск и подстановку данных

Есть таблица с названиями деталей:

Название   деталиСтелаж
Деталь AS121DD
Деталь   DSD100SDS
Деталь   DSFDSS156DSDDWW
В самом названии (всегда второе слово в ячейке) сождержится код стелажа где лежит делать
Код унинкальный (в названии товара встречается всего 1 раз и только 1 код из всего справочника)

И есть справочник соответсвия - код стелажа - название стелажа в таком вот виде:

Код в названии Где находится,

Код в   названииГде находится
100Стелаж 1
121Стелаж 2
156Стелаж 3
Нужно напротив делатей прописать Стелаж где находится делать

Название   деталиСтелаж
Деталь AS121DDСтелаж 2
Деталь   DSD100SDSСтелаж 1
Деталь   DSFDSS156DSDDWWСтелаж3

Т.е. во втором слове каждой ячейке нужно найти из справочника код (код содержится во втором слове) и по коду уже определить стелаж.

Подскажите как сделать ? Пример во вложении.
 
allalone, Добрый день,
Код
=ПРОСМОТР(2;1/(ПОИСК(справочник!$A$2:$A$4;детали!$A2));справочник!$B$2:$B$4)
Изменено: a.i.mershik - 10 Апр 2018 09:57:15
 
вариант массивная
Код
=ВПР(--ПСТР(A2;МИН(ЕСЛИОШИБКА(ПОИСК(СТРОКА($1:$10)-1;A2);"Ъ"));3);справочник!$A$2:$B$4;2;0)
Лень двигатель прогресса, доказано!!!
 
Спасибо !
Страницы: 1
Читают тему (гостей: 1)