Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Поиск предыдущей самой близкой дата и времени к заданной по нескольким условиям
 
Добрый день. Прошу помощи, имею дату "создания документа" 05.03.2018  9:47:12, имею массив ВХОД с временем, необходимо высчитать максимально приближённое время до даты "создания документа", т.е. 05.03.2018  9:47:12.Сейчас использую формулу =ИНДЕКС(A2:A12;ПОИСКПОЗ(МАКС(ЕСЛИ(A2:A8<D2;A2:A8;""));A2:A8;0)), работает, ищет,
НО у меня есть ещё одно условие, что бы искал и этот расчёт вёл строго при совпадении ФИО создал и ФИО1.
Может кто то, что то подобное делал?
 
ARV, а Вы бы могли показать не формулой, а то что есть (исходные данные) и желаемый результат!?  
Изменено: a.i.mershik - 10 Апр 2018 10:16:07
 
если правильно понял то
Код
=ИНДЕКС($A$2:$A$8;ПОИСКПОЗ(МАКС(ЕСЛИ(($A$2:$A$8<D2)*($B$2:$B$8=C2);$A$2:$A$8;""));$A$2:$A$8;0))
 
Во вложении.
Столбец А (ВХОД) - отметка прибытия водителя(т.е. за несколько дней несколько приездов и отметок)
Столбец В (ФИО водителей общий, всех, которые отметились)
Столбец С и D (ФИО водителей и время дата время сдачи документов)
Столбец Е (Непосредственно формула выше, которая ищет самое последнее время  прибытия водителя из столбца А к времни создания документа столбец D),без учёта ФИО.

В этом и проблема , что в массиве столбца А общее время прибытия по всем водителям и формула считает по всему массиву времени не учитывая ФИО водителя который сдал документ , а нам необходимо последнее время прибытия именно по определённому водителю.
 
ARV, вы можете ручками проставить ВЕРНЫЕ Результаты в ФАЙЛЕ (ЧТО ПРАВИЛЬНО ДОЛЖНО ПОЛУЧИТСЯ)
 
StepanWolkoff, всё работает, большое спасибо, а то я всю голову сломал.  

Изначально требовалось найти разницу во времени сдаче водителем документов и последней GPS отметки о его  прибытии, но отметок GPS оказалось множество, т.е. водители приезжают и сразу доки не сдают, а как таких нарушителей выявить за месяц был вопрос, теперь похоже решился.В файле выгрузка лист водители, лист создание документов и свод, с вашей формулой подтягивает нужное
Страницы: 1
Читают тему (гостей: 1)