Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Подсчитать количество плановых рабочих дней по условию
 
Добрый вечер, помогите, пожалуйста, подсчитать количество плановых дней по условию
.
 
Здравствуйте. Для столбца F формула у Вас есть. Для столбца Е можно использовать такую
Код
=СУММПРОИЗВ((МЕСЯЦ($C$5:C5)=МЕСЯЦ(C5))*($D$5:D5>0))
 
gling, спасибо Вам большое.  
.
 
Для Е6:
=ЕСЛИ(МЕСЯЦ(C6)=МЕСЯЦ(C5);СУММ(E5;(D6<>0));1)

И подумайте, сколько времени Вы ждали бы ответ с той функцией из предыдущей темы...
 
vikttur,  может как то неправильно использую Ваш вариант, но он дает циклическую ссылку  
.
 
Заменил МЕСЯЦ(C3) на МЕСЯЦ(C5). Но не эта опечатка вызвала зацикливание. Вы точно в строку 6 формулу ставите?
 
vikttur, дает неправильный подсчет в феврале, пожалуйста, расскажите подробнее, почему не видно выражение в строке формул?  
.
 
Где?
 
с 1 по 4 февраля в колонке Е.  И почему - то не видно самого выражения в строке формул.
.
 
vikttur, а почему не просто E5+(D6<>0) , а в SUM обернуто?
 
Что Вы показали? Где там моя формула?
 
Формулы в строке формул отображаются.
 
виноват, присоединил не тот файл  
.
 
Цитата
БМВ написал:  почему не просто E5+(D6<>0)
Аппендикс. Начал писать для строки 5...
 
Цитата
vestes написал:
виноват, присоединил не тот файл  
Внимательнее нужно быть - отнимаете чужое время. И в последнем файле формулы отображаются.
 
E5 и далее
=(D5<>0)+IF(MONTH(C5)=IF(ISNUMBER(C4);MONTH(C4);0);E4;)
Изменено: БМВ - 10 Апр 2018 22:40:33
 
Цитата
Юрий М написал: Внимательнее нужно быть - отнимаете чужое время
Цитата
vikttur написал: Заменил МЕСЯЦ(C3) на МЕСЯЦ(C5). Но не эта опечатка вызвала зацикливание
 
gling, vikttur, Юрий М, БМВ Большое спасибо!  
.
Страницы: 1
Читают тему (гостей: 1)