Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Округление числа со смещением на 0,19 влево до значения кратного 0,5
 
Как реализовать формулу?

от 31,7 до 32,1 =32
от 32,2 до 32,6 = 32,5
от 32,7 до 33,1 = 33
от 33,2 до 33,6 = 33,5
от 33,7 до 34,1 = 34
от 34,2 до 34,6 = 34,5
от 34,7 до 35,1 = 35

и т.д., числа до запятой будут постоянно меняться
Изменено: warezoc - 11 Апр 2018 11:46:15
 
warezoc, функция =ОКРУГЛТ
Изменено: a.i.mershik - 11 Апр 2018 11:47:34
 
если можно напишите пример формулы:)
 
warezoc,

=ОКРУГЛТ(3,7;0,5)  

Но если честно вообще не понятно что вы делаете.... файл пример сделайте и покжажите что еть и что нужно

Изменено: a.i.mershik - 11 Апр 2018 11:55:02
 
Цитата
a.i.mershik написал:
Но если честно вообще не понятно
Так отож. Судя по всему никакой математики в этом округлении нет.
warezoc,  попробуйте ВПР с неточным поиском.
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
 
Bema, может просто здесь присвоение значение диапазону....
 
это курс евро в гривне, выставляется в прайсе автоматически, так округляют вручную
хочу чтобы это делалось автоматически
Изменено: warezoc - 11 Апр 2018 12:00:32
 
warezoc, приложите файл пример
 
а2 курс евро
b2 округленный курс (нужно)
 
warezoc, если Вы хотите универсальную мат. формулу под придуманное Вами правило, то это не просто. Но вы можете прописать исключение для каждого случая, а потом объединить все исключения. Например =ЕСЛИ(И(A1>33;A1<34);33.5)
Вся проблема сложных программ, целых томов кодов и состоит в несоблюдении принципа лезвия Оккама: «Не следует множить сущее без необходимости». Вся гениальность в простоте.
 
Попробуйте так:
Код
=ОКРВВЕРХ(A2-0,2;0,5)

И еще у вас условия прописаны не очень хорошо. Нужно точно определиться куда попадают граничные значения, и значение равное, например 32,69 ?
Изменено: PooHkrd - 11 Апр 2018 12:14:45
 
хотел сразу прописать, подумал лишнее

от 31,7 до 32,19 =32
от 32,2 до 32,69 = 32,5
от 32,7 до 33,19 = 33
от 33,2 до 33,69 = 33,5
от 33,7 до 34,19 = 34
от 34,2 до 34,69 = 34,5
от 34,7 до 35,19 = 35
 
=ЕСЛИ(И(A1>=31,7;A1<=32,1);32;ЕСЛИ(И(A1>=32,2;A1<=32,2);32,5;ЕСЛИ(И(A1>=32,7;A1<=33,1);33;ЕСЛИ(И(A1>=33,2;A1<=33,6);33,5;ЕСЛИ(И(A1>=33,7;A1<=34,1);34;ЕСЛИ(И(A1>=34,2;A1<=34,6);34,5;ЕСЛИ(И(A1>=34,7;A1<=35,1);35)))))))

Адаптируй числа до запятой и всё готов
Вся проблема сложных программ, целых томов кодов и состоит в несоблюдении принципа лезвия Оккама: «Не следует множить сущее без необходимости». Вся гениальность в простоте.
 
Цитата
PooHkrd написал:
Попробуйте так:Код ? 1=ОКРВВЕРХ(A1-0,2;0,5)
Это вернее =ОКРВВЕРХ(A1-0,19;0,5)
Вся проблема сложных программ, целых томов кодов и состоит в несоблюдении принципа лезвия Оккама: «Не следует множить сущее без необходимости». Вся гениальность в простоте.
 
=ОКРВВЕРХ(A2-0,19;0,5)
этот код работает)
Всем огромное спасибо за помощь!!!
 
Только имейте ввиду, что 31,699 окуглится до 32, а по идее должен до 31,5
 
Утчните название темы. Какая логика округления? Посему именно так? Модераторы поменяют.
 
По ходу ТС ушел.
Предлагаю тему:
"Округление числа со смещением на 0,19 влево до значения кратного 0,5"
Страницы: 1
Читают тему (гостей: 1)
Наверх