Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Среднее значение отработанного времени
 
Подскажите, пожалуйста, как решить такую задачу.
Есть список сотрудников с такими данными: город, должность, дата приема, дата увольнения. Надо просчитать формулой например такое.
сколько В СРЕДНЕМ дней отработали бухгатера в городе Киев  
 
valchik, ну без файла тяжело сказать
 
Вот пример. Данные надо представить в виде таблицы. Высчитать среднее кол-во дней
 
valchik,
Код
=СУММПРОИЗВ(($B$2:$B$90=J$1)*($C$2:$C$90=$I2)*$F$2:$F$90)/СЧЁТЕСЛИМН($B$2:$B$90;J$1;$C$2:$C$90;$I2)
 
Я правильно поняла, что в столбце F надо расчитать дни (E-d)? если да, то не подходит, так как условие задачи сделать это одной формулой БЕЗ добавление каких либо строк (((
 
a.i.mershik, да с доп столбцом это ...не знаю подумаю сейчас.
Код
=СУММПРОИЗВ(($B$2:$B$90=J$1)*($C$2:$C$90=$I2)*($E$2:$E$90-$D$2:$D$90))/СЧЁТЕСЛИМН($B$2:$B$90;J$1;$C$2:$C$90;$I2)
Изменено: a.i.mershik - 11 Апр 2018 14:07:29
 
Спасибо огромное. Получилось еще через "datedif" ))))))))))
 
разницу в E-D ($E$2:$E$90-$D$2:$D$90) в СУММПРОИЗВ подставьте
Изменено: Stics - 11 Апр 2018 14:12:08
Страницы: 1
Читают тему (гостей: 1)