Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Поиск данных в определённой строке таблицы
 
Добрый день. Уважаемые форумчане, прошу Вашей помощи.
Задача следующая:
По основному критерию (указан в столбце J), найти соответствующий критерий в столбце B таблицы B2:F23 и определить номер строки, в которой он находится. (с этим проблем нет)
Далее в указанной строке провести поиск второго критерия (указан в столбце K) и вывести название столбца, в котором находится искомое значение. Если в строке находится более одного значения, удовлетворяющего второму критерию, вывести номер столбца при первом совпадении.(Вот с этим проблема)
Надеюсь на Вашу помощь.  
 
для данного примера в L2 и вниз
Код
=ИНДЕКС($C$2:$F$2;ПОИСКПОЗ(K3;ИНДЕКС($C$3:$F$23;ПОИСКПОЗ(J3;$B$3:$B$23;0););0))
Лень двигатель прогресса, доказано!!!
 
Код
=ИНДЕКС(R2C3:R2C6;ПОИСКПОЗ(RC[-1];ИНДЕКС(R3C3:R23C6;ПОИСКПОЗ(RC[-2];R3C2:R23C2);1):ИНДЕКС(R3C3:R23C6;ПОИСКПОЗ(RC[-2];R3C2:R23C2);3);))
Программисты - это люди, решающие проблемы, о существовании которых Вы не подозревали, методами, которых Вы не понимаете!
 
Большое спасибо, всё работает =)
Страницы: 1
Читают тему (гостей: 1)
Наверх