Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Подстановка формулы вместо ссылки на ячейку, расширенные возможности ссылки на диапазон
 
Добрый вечер!
Есть стандартная формула суммы СУММ(А1:А5) , но мне хотелось бы границу диапазона привязать к какому-нибудь значению, которое, например, берётся из ячейки B1 (например равное 25), и подставляется частично вместо А5 (т.е. хочу получить диапазон А1:А25).Экспериментировал с  АДРЕС(1;2;4) , но толком ничего не получилось. Подскажите пожалуйста, как прописать формулу, чтобы опираясь на ячейку А1 как начало диапазона суммирования, считать значение ячейки B1, и получить желаемую формулу эквиваленнтную СУММ(А1:А25)?
 
Zonda,
Код
=СУММ(A1:ИНДЕКС(A:A;B1))
=СУММ(СМЕЩ(A1;;;B1))
=СУММ(ДВССЫЛ("A1:A"&B1))
 
Казанский, ого! Спасибо большое!!
Страницы: 1
Читают тему (гостей: 1)
Наверх