Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Необходимо проставить ранг команды в строке
 
Добрый день!
Прошу помочь проставить формулу (в файле выделено желтым то что должно получиться), формула РАНГ не подходит, т.к. есть повторяющиеся значения. Ранее здесь поднималась эта тема, но там формула, которая используется в случае если числа идут в столбце, а у меня обязательно должно быть в строке .
 
Из вашего примера не видна зависимость рейтинга от какого-либо параметра. Если в строке 3 указаны минимальные значения при которых присваивается соответствующий рейтинг, то решение такое:
=ЕСЛИ(C3<10;5;ЕСЛИ(C3<16;4;ЕСЛИ(C3<36;3;ЕСЛИ(C3<150;2;1))))
 
а функцией РАНГ?

=РАНГ(C3;$C$3:$H$3;0) и протянуть по диапазону

простите не увидел исходные условия  :oops:  (удалить бы сообщение)
Изменено: kalmar - 13 Апр 2018 13:22:18
 
=MATCH(C3+COLUMN(C3)/10^9;LARGE($C$3:$H$3+COLUMN($C$3:$H$3)/10^9;ROW($A$1:INDEX($A:$A;COUNTA(2:2))));0)

пардон, нужно чтоб не 6 а 5 мест,  и два 4
Изменено: БМВ - 13 Апр 2018 13:22:21
 
Цитата
Tezaurus написал:=ЕСЛИ(C3<10;5;ЕСЛИ(C3<16;4;ЕСЛИ(C3<36;3;ЕСЛИ(C3<150;2;1))))
Это, к сожалению, не подойдет, т.к. само кол-во в командах может меняться, нужна уникальная формула.
Изменено: Oksana2311 - 13 Апр 2018 19:46:05
 
Цитата
Oksana2311 написал:
уникальная формула
Универсальна наверно ?
 
Да, универсальная  :)  
Изменено: Oksana2311 - 13 Апр 2018 13:58:15
 
Массивная, и скорее всего что усложнил, но отвлекают не домыслить.

=MATCH(C3;LARGE(INDEX($C$3:$H$3;N(INDEX(MATCH($C$3:$H$3;$C$3:$H$3;0);N(INDEX(ROW($A$1:INDEX($A:$A;MAX(MATCH($C$3:$H$3;$C$3:$H$3;0))));0)))));ROW($A$1:INDEX($A:$A;MAX(MATCH($C$3:$H$3;$C$3:$H$3;0)))));0)

Не жмакайте по чем зря цитирование, и поправьте свои посты ну какой смысл от цитаты в #7
 
Формула массива:
=ПОИСКПОЗ(C3;НАИБОЛЬШИЙ(ЕСЛИ(ПОИСКПОЗ($C$3:$H$3;$C$3:$H$3;0)=СТОЛБЕЦ($C$3:$H$3)-2;$C$3:$H$3);СТРОКА(1:10));0)
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
 
Спасибо большое за помощь!
Страницы: 1
Читают тему (гостей: 1)
Наверх