Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Расчет с контрагентами за период
 
Как сделать калькулятор расчета с контрагентами из выпадающего списка за заданный самостоятельно период? Есть 4 контр агента, и целая таблица с операциями(дата, сумма, контрагент), как сделать калькулятор, чтобы можно было ввести дату начала периода, дату окончания, выбрать контрагента, и чтобы он автоматически рассчитал сумму всех операций по выбранному контрагенту и заданному периоду?
Изменено: timbour - 13 Апр 2018 15:51:07
 
You made my Day!!!  :D
Вы действительно считаете что исходных данных достаточно для оказания вам помощи?
 
Как вариант:https://www.excel-vba.ru/forum/index.php?topic=1786.0
 
timbour, приложите файл пример где покажите что есть и рядом что нужно получить.
 
timbour, судя по описанию, подобный "калькулятор" можно сделать, используя формулу СУММПРОИЗВ. Выложите пример - всё станет ясно
 
добрый день
Код
=СУММЕСЛИМН(C:C;B:B;G6;A:A;">="&H4;A:A;"<="&J4)
 
timbour, еще вариант через суммпроизв
Код
=СУММПРОИЗВ(($B$2:$B$15=$G$6)*($A$2:$A$15<=$J$4)*($A$2:$A$15>=$H$4)*$C$2:$C$15)

или формула массива

Код
=СУММ(($G$6=$B$2:$B$15)*(($A$2:$A$15<=$J$4)*($A$2:$A$15>=$H$4))*C2:C15)
Изменено: a.i.mershik - 13 Апр 2018 16:45:47
Страницы: 1
Читают тему (гостей: 1)