Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Поиск последнего ненулевого значения с выведением имени этого столбца
 
Помогите, пожалуйста, написать формулу. Есть тысяча заказов , множество аналитики к ним, и 24 столбца. 12 месяцев и каждый месяц делится на затраты и списание. Как мне вывести в конце формулу, чтоб он искал последнее ненулевое значение ( то есть показывал в каком месяце последний раз были затраты или списание) , и выводил название этого месяца
 
Пример в формате Эксель нужен. Что есть, что хотите получить.
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
 
.Какую формулу надо сделать , чтоб в последнем столбце выводилось, как в данном пример, август, то, что последние затраты были в августе месяце.
 
Формула массива. Вводить тремя клавишами.
=ИНДЕКС(B1:Y1;;МАКС(ЕСЛИ(ПРАВСИМВ(B1:Y1;5)="затр.";ЕСЛИ(B2:Y2<>0;СТОЛБЕЦ(B1:Y1)-1))))
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
 
А можете помочь разобраться в ней, что из чего следует, помочь понять ее и суметь применять в других таблицах? Еще в формуле фигурирует слова затрат, а если надо проверить в каком месяце было послдние либо затраты либо списание, она действует, найти последний ненулевой месяц и вывести его?  
Изменено: olga18082006 - 14 Апр 2018 16:10:20
 
Цитата
olga18082006 написал:
а если надо проверить в каком месяце было послдние либо затраты либо списание
Поменяйте в формуле "затр." на "спис.".
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
 
А поясните пожалуйста, почему используем во вкладке формулы функцию максимум?  
 
  1. В строке 1 ищем ячейки содержащие затраты.
  2. В строке 2 ищем ячейки не равные нулю.
  3. Где выполняются оба эти условия, получаем номер столбца.
  4. Для этого примера получаем вот такой массив: {1;ЛОЖЬ;ЛОЖЬ;ЛОЖЬ;5;ЛОЖЬ;7;ЛОЖЬ;ЛОЖЬ;ЛОЖЬ;ЛОЖЬ;ЛОЖЬ;ЛОЖЬ;ЛОЖЬ;15;ЛОЖЬ;ЛОЖЬ;ЛОЖЬ;ЛОЖЬ;ЛОЖЬ;ЛОЖЬ;ЛОЖЬ;ЛОЖЬ;ЛОЖЬ}
  5. Естественно нам нужно взять максимальное значение, что и делает МАКС.
  6. Ну а дальше ИНДЕКСОМ извлекаем месяц.
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
 
Спасибо огромное за помощь и разьяснение. Можно тогда еще вопрос зачем в конце формулы -1?
 
Если убрать -1, то получим массив:
{2;ЛОЖЬ;ЛОЖЬ;ЛОЖЬ;6;ЛОЖЬ;8;ЛОЖЬ;ЛОЖЬ;ЛОЖЬ;ЛОЖЬ;ЛОЖЬ;ЛОЖЬ;ЛОЖЬ;16;ЛОЖЬ;ЛОЖЬ;ЛОЖЬ;ЛОЖЬ;ЛОЖЬ;ЛОЖЬ;ЛОЖЬ;ЛОЖЬ;ЛОЖЬ}
а ИНДЕКСу нужно  передать номера столбцов начиная с 1.
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
 
Понятно, спасибо огромное.
Страницы: 1
Читают тему (гостей: 1)