Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Подсчёт соц.услуг специалистов для семей по категориям, Вывод списка членов семьи с подсчётом услуг каждым специалистом
 
Здравствуйте. Недавно помогал центру с переходом от бумажного в цифровой учёт табелей услуг. Производится пересчёт оказанных услуг 4 специалистов матерям и детям в нескольких категориях. Вёл услуги по специалистам для каждой семьи. Ближе к концу месяца по этим данным понадобилось сделать два листа с отчётами: один общий по услугам матерей и детей, другой отдельно для каждой семьи.
В общем отчёте суммируется диапазон (листы {:}) постоянных семей по дополнительным таблицам и формула всегда привязывается к одной ячейке. Из-за этого после добавления новой услуги таблица сместится и будет выдавать неверный результат.
Для срочной семьи подсчитывает только по её собственному листу. Листы всегда имеют фамилию и инициалы семьи, у меня не удаётся сделать привязку формулы к ячейки с названием листа.
Заблокировал на всех листах ячейки с формулами, серые ячейки доступны для редактирования.
Возник вопрос как с помощью ячейки, указывающей на лист семьи сделать вывод списка членов семьи и провести подсчёт услуг для них каждым специалистом?

P.S. Также моя тема на других форумах
Форум программистов
Мир MS Excel
Киберфорум
Изменено: Wrascon - 16 Апр 2018 09:42:50
 
Офигеть можно!
Посмотрел перечень "услуг", за которые эти "соцработники" бабло рубят :)
И каждый день новый РАЬОТНИК! :)
Они лично, чтоли каждый день выгоняют  из помещения и снова загоняют постояльца?
Никаких слов нет.
Умножайте всё на - 50.
Пусть еще платят, что жопы просиживают.
Пред   площади
Пред   помещений для организайии реабилитации
Пред мебели
Предос   питания
Обеспеч   мягким инвентарём
Уборка жилого   помещения
Предост   транспорта
Оказание   прачечных услуг
Обеспеч   сохранности вещей
 
Конкретно в моём случае есть 4 специалиста, которые целые сутки и появляются на работе 7 раз за месяц. Им приходится не только следить за порядком, решать семейные проблемы и зачастую быть даже воспитателем, но под конец рабочего дня всего 2 месяца назад их основным якорем была тонна макулатуры и вычисления на калькуляторе без какого либо компьютера. С их появлением они стали клепать себе несвязанные таблицы без каких либо формул и всё также вручную как на бумаге. Лишь половина из них подсуетились и добавили первую функцию СУММ. За месяц таблицы семей приобрели хоть какой-то общий вид, но вторая половина стала лезть в форматирование и изменение формул на свои цифры. Тогда я сделал им боковую таблицу, которая искала специалиста в общем списке месяца и если тот проставлял услугу суммировал её.
Код
=СУММЕСЛИМН($C14:$AG14;$C$3:$AG$3;AJ$3)
Оно считало всё верно до тех пор, пока перестали совпадать имена. Оказалось они банально стёрли инициалы. И ведь действительно. Будь вся эта система табелей в каком-то подобии 1С Предприятии не было бы путаницы в отчётах и непозволительных исправлений со стороны нижнего персонала. Даже на таком деньги экономят, а те по прежнему ловят палки в колёса. Поставили всех на слуху о возможном внедрении УСОН, но до самой системы дело не дошло.
Приходится своими знаниями упрощать им работу, но они ставят такие условия, что я сам не настолько могу в программирование автоматического распознавания таблицы, чтобы та разворачивала все данные на новом листе по одному указанию ячейки. Было лишь предположение, что это сводная таблица, посмотрел и восхитился силе формул с этого видео. Думаю, когда-нибудь получится сделать нечто подобное.
Изменено: Wrascon - 14 Апр 2018 20:36:18
 
Кросс
 
Wrascon, нехорошо... Размещаете тему на нескольких форумах - информируйте об этом.
 
Юрий М, добавил ссылки в конце поста
 
По листу "Семейный отчёт"
Код
=СУММЕСЛИМН('Семья с 1'!C5:AG5;'Семья с 1'!C3:AG3;C$3)
Как будет правильнее разбить эту формулу для пересчёта через ячуйку, указывающую на отдельную семью?
Пробовал следующую, где $A$2 название листа нужной семьи, C5:AG5 месячный диапазон услуги, C3:AG3 месячная смена специалистов, C$3 специалист, по которому нужно провести подсчёты.
Код
=СУММЕСЛИМН(ДВССЫЛ($A$2&"!"&C5:AG5);ДВССЫЛ($A$2&"!"&C3:AG3);C$3)
Помимо этой функции мне нужно узнать как вывести список семьи по ячейкам "Мать:", "Ребёнок 1:", "Ребёнок 2: ", "Ребёнок 3: ", "Ребёнок 4: ", "Ребёнок 5: "

По листу "Общий отчёт"
Единственное меня не покидает опасение, что формула по всем листам указанного диапазона "{:}" не адаптируется под изменения в таблице. Любое изменение даже во всех листах оставит операцию на той же самой ячейке
Код
=СУММ('{:}'!AJ14)
У детей всё куда хуже. После добавления новой услуги все ячейки придётся указывать вручную для каждого ребёнка снова
Код
=СУММ('{:}'!AJ49;'{:}'!AJ88;'{:}'!AJ127;'{:}'!AJ166;'{:}'!AJ205)
 
Изменил файл пример как устроена таблица. Сам вопрос касается только последних двух листов с отчётами
 
зачем столько лишней информации в файле с кучей примечаний с таким примером долго будете ждать помощи
Лень двигатель прогресса, доказано!!!
 
Сергей, Что для вас есть пример? Для меня лист с одной полной семьёй, срочная семья и пару листов с отчётами, которые ссылаются на оба предыдущих листа. Я не могу перефразировать таблицу не потеряв связь ячеек для формул, где оказание услуги детей отличается от взрослых отсутствием целых категорий. Что мне стоит оставить в ней, если все ячейки указываются вручную, а не автоматически при нахождении Мать - с/быт - итого, Мать - с/пед - итого и так же с детьми. Формула не перетаскивается вниз и её по прежнему приходится корректировать для каждой строчки отдельно.
Если под примером подразумевается шаблон как должно выглядеть в итоге, мне неминуемо придётся указывать все эти моменты в примечаниях. Уж поверьте, тоже непонимание происходило при виде таблицы с вручную забитыми цифрами без формул.
Страницы: 1
Читают тему (гостей: 1)