Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Вывод списка при условии
 
Здравствуйте! Очень прошу помощи.

Есть 3 столбца: название дома, максимальная стоимость и реальная стоимость.

В 4 столбец нужно вывести только названия тех домов, реальная стоимость которых выше, чем максимальная.
Сейчас получается, что выводит дома и 0, если условие не выполняется. Нули не могу никак убрать. Хотелось бы, чтобы были только названия домов.
Изменено: Lera1993 - 14 Апр 2018 18:41:51
 
Lera1993, здрасьте. Можно отключить отображение нулей в Параметрах. Или так:
=ЕСЛИ(C2>B2;A2;"")
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
 
Тогда остаются пустые ячейки) Можно как-нибудь без них?  
 
Вариант с доп. столбцом:
=ЕСЛИ(D2>C2;СТРОКА();"")
=ЕСЛИОШИБКА(ВПР(НАИМЕНЬШИЙ($A$2:$A$11;СТРОКА()-1);$A$2:$B$11;2;0);"")
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
 
Спасибо большое!
Страницы: 1
Читают тему (гостей: 1)