Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Перенести слово в другую ячейку по условию
 
Привет! Как доработать эту формулу, которая переносит последнее слово из наименования в другую ячейку так, чтобы в другую ячейку переносилось только "из"?
Код
=ЕСЛИ(НЕ(ЕОШ(НАЙТИ(" из";RC[-1])));СЖПРОБЕЛЫ(ПРАВБ(ПОДСТАВИТЬ(RC[-1];" ";ПОВТОР(" ";50));50));0)
 
У Вас по выходным файлы-примеры не выдают?
Цитата
чтобы в другую ячейку переносилось только "из"
Без примера так:
=ПОДСТАВИТЬ(A1;" из";)
а в соведней ячейке написать "из"
 
Спасибо за правильное оформление моего поста!
Прилагаю пример.
Изменено: focus_td0 - 15 Апр 2018 13:04:47
 
Цитата
focus_td0 написал: переносилось только "из"
ТОЛЬКО именно этот предлог при его наличии? Или что?
Согласие есть продукт при полном непротивлении сторон.
 
Замените файл. Покажите результат, не нужен пример с формулой.
 
Да, именно этот предлог при его наличии. При этом предлог должен быть последним словом в ячейке.
 
=ЕСЛИ(ПРАВБ(A1;3)=" из";формула_из_сообщения_№2)
 
Код
=ЕСЛИ(СЖПРОБЕЛЫ(ПРАВБ(ПОДСТАВИТЬ(A1;" ";ПОВТОР(" ";50));50))<>"из";0;"из")
Согласие есть продукт при полном непротивлении сторон.
 
Спасибо, работает!  
 
На будущее: в этом вопросе при наличии примера в первом сообщении во втором получили бы полный ответ.
И не нужно спрашивать: на велосипеде доехал до речки, где нет моста... как на этом велосипеде перебраться на другой берег?
 
И я поворчу по терминологии:
Цитата
focus_td0 написал:
Перенести слово в другую ячейку
Перенести - это значит изъять слово из одной ячейки и переместить его в другую. А формулы этого делать не умеют.
Страницы: 1
Читают тему (гостей: 1)