Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
суммирование по двум критериям, Как просуммировать по двум критериям
 
Добрый день, уважаемые знатоки экселя. Есть сводная таблица, в которой собираются данные с другого листа. формула суммеслимн не помогает, так как поиск критериев  выполняется как горизонтально, так и вертикально.
 
Код
=СУММПРОИЗВ('по датам'!$D$3:$K$5*('по датам'!$B$3:$B$5=$B3)*('по датам'!$D$2:$K$2=D$2))
Программисты - это люди, решающие проблемы, о существовании которых Вы не подозревали, методами, которых Вы не понимаете!
 
Если преобразовать исходные данные в плоскую таблицу, то результат можно будет получать очень легко, быстро и в разных видах с помощью инструмента "Сводная таблица".
Если автоматизировать бардак, то получится автоматизированный бардак.
 
Ігор Гончаренко, Спасибо большое!!! То что надо!
 
wowick, да можно, но здесь принципиально формулы нужны были.
Страницы: 1
Читают тему (гостей: 1)