Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Сдаюсь. Подсчет кол-ва строк, где одно из условий - сумма значений ячеек (несколько столбцов) в такой строке >0.
 
Добрый день. Замкнуло мозг + слабое знание массивных формул.
Такую задачу задали. В таблице продажи, по каждому менеджеру клиенты, вправо столбцы месяцев с продажами. Не могу подсчитать кол-во ненулевых строк по каждому менеджеру. Служебный столбец для суммирования и последующий счётеслимн организовывать нельзя. Пример прикладываю. Пользуясь случаем выражаю огромное уважение и благодарность мэтрам форума. Сколько лет уже читаю, правда не сильно поумнел.
Изменено: miked - 17 Апр 2018 12:09:50 (более понятная формулировка темы)
 
Как вариант добавить доп столбец "квартал" и посчитать через формулу СЧЕТЕСЛИМН
 
Очень жаль, честно говоря, что нормального ответа ни от кого не дождался, хотя бы, что "это нельзя сделать". Реально интересно решение.
 
=СУММ((МУМНОЖ(--НЕ(ЕПУСТО(R2C3:R5C5));{1:1:1})>0);--(R2C2:R5C2=RC10))
формула массива (для Первый, 1-й кв.)
Программисты - это люди, решающие проблемы, о существовании которых Вы не подозревали, методами, которых Вы не понимаете!
 
Ігор Гончаренко, НЕ ОПЕЧАТКА? =СУММ((МУМНОЖ(--НЕ(ЕПУСТО(R2C3:R5C5));{1:1:1})>0);--(R2C2:R5C2=RC10))
скорее так
=СУММ((МУМНОЖ(--НЕ(ЕПУСТО(R2C3:R5C5));{1:1:1})>0)*(R2C2:R5C2=RC10))
или совсем так
=SUM((MMULT(NOT(ISBLANK($C$2:$H$5))*(INT((COLUMN($C$2:$H$5)-3)/3)+1=--LEFT(K$2;1));(TRANSPOSE(COLUMN($C:$H))-2)^0)>0)*($B$2:$B$5=$J3))
 
Не массивная формула для К3
=СУММПРОИЗВ(Ч(МУМНОЖ((C$2:E$5>0)*(B$2:B$5=J3);{1:1:1})>0))
Алексей М.
 
Спасибо всем за отклик огромное! Даже не догадывался про МУМНОЖ. Какая классная штука. Но внутри СУММПРОИЗВ особенно изящно выглядит!
Страницы: 1
Читают тему (гостей: 1)
Наверх