Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Вытянуть данные по определённому порядку
 
Сделал формулами, но кажись сложно, можно-ль попроще?
 
Можно через ВПР с вашим доп. столбцом
 
в G2 и вниз формула массива
Код
=ЕСЛИОШИБКА(ИНДЕКС($D$2:$D$30;НАИМЕНЬШИЙ(ЕСЛИ($C$2:$C$30=F2;СТРОКА($C$2:$C$30)-1);СЧЁТЕСЛИ($F$2:F2;F2)));"")
Лень двигатель прогресса, доказано!!!
 
Arturus,
Сергей, особо, без дополнительных столбцов
спасибо , работает
Изменено: Геннадий - 17 Апр 2018 14:53:59
 
формула без массивного ввода
Код
=IFERROR(INDEX($B$2:$B$32;MATCH(1;INDEX((COUNTIF(E$1:E1;$B$2:$B$32)=0)/($A$2:$A$32=D2);0);0));"")
 
Цитата
jakim написал:
формула без массивного ввода
спасибо, ещё круче
Изменено: Геннадий - 18 Апр 2018 10:06:53
Страницы: 1
Читают тему (гостей: 1)