Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Поделить два столбца и сложить, Деление, сложение столбцов
 
Есть два столбца данных, грубо:
А1 = $
B1 = Сумма
Необходимо
1. все данные из столбца "В"(сумма) поделить построчно на данные столбца "А"($)
2. а затем сложить все построчные результаты
Как работает СУММПРОИЗВ мы знаем,
А как реализовать ДЕЛЕНИЕ
За ранее Спасибо
 
Формула массива:
=СУММ(B1:B4/A1:A4)
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
 
Код
=СУММПРОИЗВ(1/A1:A3;B1:B3)
 
Цитата
Bema написал:
=СУММ(B1:B4/A1:A4)
Цитата
webley написал:
=СУММПРОИЗВ(1/A1:A3;B1:B3)
НЕ ребят
не работает ни то ни другое
Изменено: vlash72 - 17 Апр 2018 16:40:57
 
Цитата
vlash72 написал:
не работает ни то ни другое
Докажите. У меня работает.
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
 
формулу вводили через ctrl+shift+enter ?
 
странно
НО
*****
сорри
работает
Для упрощения, так как значений в столбце очень много я указываю столбец так  >> D:D, а не D1:D1002
И вот выходит если столбец взять - то ОШИБКА, а если указать ячейками - СЧИТАЕТ
 
Цитата
vlash72 написал:
странно
Действительно, странно:
Цитата
vlash72 написал:
все данные из столбца "В"(сумма) поделить построчно на данные столбца "А"($)
Цитата
vlash72 написал:
Для упрощения, так как значений в столбце очень много я указываю столбец так  >> D:D, а не D1:D1002
Да, в формуле должен быть определенный диапазон со значениями. Его можно получить так:
Код
D1:ИНДЕКС(D:D;СЧЁТ(D:D))
Изменено: Казанский - 17 Апр 2018 16:55:09
 
Цитата
vlash72 написал:
странно
ничего странного - при выделении столбца получается деление на ноль (кстати, ошибка так и звучит)
можно модифицировать формулу, но вводить уже надо как формулу массива:
Код
=СУММПРОИЗВ(ЕСЛИОШИБКА(1/A:A;0);B:B)
Изменено: webley - 17 Апр 2018 17:00:49
 
Цитата
webley написал:
при выделении столбца получается деление на ноль
точно))))) - спасибо
то есть необходимо условие добавить - если  ЕРРОР - то  0 (ничего)
и это может быть так:
=СУММПРОИЗВ(В:В;IFERROR(1/(А:А);0))
выходит что только так
Изменено: vlash72 - 17 Апр 2018 17:00:41
Страницы: 1
Читают тему (гостей: 1)