Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Поиск значения в зависимости от даты
 
Добрый день уважаемые форумчане

Просьба помочь в решении одной, как мне кажется простой, задачки

Есть лист Реестр, на нем таблица, в которую вносятся заказы по определенному поставщику
На листе Поставщики, таблица с названием поставщиков, датами начала и окончания контракта, а также номером контракта

При поступлении нового заказа, на лист Реестр забивается дата заказа и из выпадающего списка выбирается поставщик.
Как на основе даты заказа подтягивать на лист Реестр номер контракта поставщика, который используется в рамках данного периода ?

К примеру если заявка для поставщика ООО "Рога и копыта" была сделана 10.06.2018, то подтянуть номер контракта 10005555322 (который действует с 01.06.2018   по 30.09.2018)

Спасибо за помощь
 
добрый день
если номер контракта всегда число, то можно так:
Код
=СУММЕСЛИМН(поставщики!D:D;поставщики!A:A;B2;поставщики!B:B;"<="&A2;поставщики!C:C;">="&A2)
 
если сможете объединить...
но допстолбец с поиском ближайшей (соответствующей) даты и далее поиск по двум критериям
может дальше подскажут
Изменено: kalmar - 26 Апр 2018 15:50:11
Страницы: 1
Читают тему (гостей: 1)
Наверх