Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Выделение нескольких диапазонов дат и их пересечений в календаре.
 
Здравствуйте!
Прошу помощи в победе на УФ.
Воспользовался чудесной формулой "вечного" календаря:
https://www.planetaexcel.ru/techniques/6/189/
И появилась идея попробовать визуализировать на нем, условно скажем, отпуска сотрудников.
Соответственно получается что диапазонов несколько с и по в столбик.
Пытаюсь использовать формулу для УФ =И(B4>=$AX8;B4<=$AY8), но ничего не выделяется. Выделяется только =И(B4>=$AX$8;B4<=$AY$8), но само собой только первый диапазон.
Подскажите пожалуйста что не так? И как выделить отдельным цветом в случае пересечения диапазонов.
Заранее благодарю!
 
GRIM,Вариант.
Изменено: Александр П. - 4 Июн 2018 06:10:09
 
Александр П., Спасибо огромное!
А как бы ещё сделать выделение пересечений дат?
 
GRIM,  Добрый день, для пересечений.
Код
=СУММПРОИЗВ((B4<=$AY$8:$AY$26)*(B4>=$AX$8:$AX$26)*(B4<>""))>1
 
Ещё раз большое спасибо!
Все работает.
Страницы: 1
Читают тему (гостей: 1)
Наверх