Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Возвращение значения присвоенного диапазону дат по двум переменным
 
Добрый день!
Помогите, пож-та, решить след.задачу:
Есть наименование товара и дата его продажи, необходимо найти номер акции по которой данный товар был продан.
Номера акции хранятся в виде "период действия/товар/номер акции".
В программировании не силен, если можно, то просто формулой или массивом.
Пример во вложении.
Спасибо!
 
=СУММЕСЛИМН(P:P;O:O;B2;M:M;"<="&A2;N:N;">="&A2)
=СУММПРОИЗВ(--(B2=$O$2:$O$8);--(A2>=$M$2:$M$8);--(A2<=$N$2:$N$8);$P$2:$P$8)


А если на дату для товара действует более одной акции?
 
Верно, в одну и туже дату может действовать несколько акций, но они обязательно будут с разным товаром.
 
В таком случае пользуйтесь любой из формул. На большом диапазоне акций первая должна работать быстрее
 
Супер, попробовал на реальном отчете, работает просто отлично.
Огромное, спасибо!
Страницы: 1
Читают тему (гостей: 1)
Наверх