Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Поиск дубликатов по трем и более условий
 
Добрый день!

Кроме поиска дубликатов условным форматированием никакой информации в интернете найти не смог.
Необходимо определить наличие дубликата по ряду критериев.

Пример поиска одного дубликата ниже.
1. Берется номер маршрута 333 из ячейки "B2",
2. Ищутся совпадения в столбце "B".
3. Находятся совпадения в ячейках "B3", "B5", "B7", "B9".

Далее проверяется соответствие дата из ячейки "С2" ячейкам "С3", "С5", "С7", "С9" по условию:
<=30 дней
1. Ищется ближайшая дата, перед искомой.  Это будет ячейка "С9"
2. Проверяется соответствие "D2" c "D9" - не соответствует
4. Ищется ближайшая дата следующая за "С9". Это будет ячейка "С7"
5. Проверяется соответствие "D2" c "D7" - соответствует
6. Значение "Да" возвращается в ячейку "E2"
7. Значение "A7" возвращается в "F2"

Буду рад любым советам! Спасибо!
 
Решение
 
Огромное спасибо!!!
 
Еще раз спасибо, за формулу в столбце F. Значительно облегчила работу, но никак не могу разобрать формулу в столбце G и возникла необходимость в определении дубля и  выносе значения из ячеек A по дополнительным критериям в столбце I.

Если есть возможность объясните какие правки внести в формулу. Алгоритм подсчета дублей по критерию руками под спойлером.
Если задача громоздкая для бесплатной помощи, то подскажите куда обратиться за платной :)
Скрытый текст
 
Цитата
Sabiaverus написал:
подскажите куда обратиться за платной
Перенести тему в платный раздел?
 

Проблему решил формулой:

Код
=ЕСЛИ(F2="Да";МАКС(ЕСЛИ((G:G =J$5)*(B:B=B2)*(D:D=D2)*(C:C=МАКС(ЕСЛИ((G:G=J$5)*(B:B=B2)*(D:D=D2)*(C:C<=C2)*(C:C<>C2)*(C:C>C2-30);C:C)));A:A));"")

Но при протягивании более чем на 1000 ячеек excel "умирает". Каким способом можно ее оптимизировать?

 
Целые столбцы нельзя указывать в формулах массива, если на их основе образуются массивы. Вместо "G:G" (и других) указывайте максимальную строку. Например, если Вам известно, что на листе не будет больше 1000 строк, то так: G1:G1000. Если заранее не известно, сколько может быть строк, то ищите последнюю строку. Можно сделать "имя" и в него записать формулу по поиску последней строки и затем имя подставлять в формулу.
 
Karataev, Огромное спасибо! Все летает.
Страницы: 1
Читают тему (гостей: 1)