Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Извлечение чисел из текста (для диапазона)
 
Не могу самостоятельно найти выход из сложившейся ситуации. Обращаюсь к вашим светлым умам. В строке 2 есть ячейки с данными в формате "цифра или число/буквенное значение". Нужно посчитать сумму чисел, например, для буквы "К" (12/К, 3/К - должна быть сумма 15.) Для одной ячейки у меня хватает ума прописать формулу (в прикрепленном файле), для диапазона же нет. Буду благодарен любой помощи!
 
У Вас циклические ссылки, что не хорошо.

формула массива:
=СУММ(ЕСЛИОШИБКА(ЕСЛИ(ПРАВБ(A2:U2;2)=A7;--ПОДСТАВИТЬ(A2:U2;A7;));0))
 
=СУММ(ЕСЛИОШИБКА(--ЕСЛИ(ПРАВБ(A2:U2;2)=A7;ПОДСТАВИТЬ(A2:U2;A7;));))
Формула массива, вводится тремя клавишами.

Во второй строке циклическая ссылка. Устраните.
 
Catboyun, работает как нужно, но есть одна загвоздка. Если ввести, например "7-15/К", то подсчет выдает неккоректные значения. Хотя проблема не смертельная (если вводить "к" маленькое, то подсчёт не сбивается)

Спасибо большое за помощь!
Страницы: 1
Читают тему (гостей: 1)
Наверх