Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Автозаполнение ячеек по дате и критерию
 
Добрейшего вечерочка.
Помогите пожалуйста. Нужно сделать так, чтобы по формуле в таблицу «Статистика» автоматически вбивалось в ячейку надпись «В срок», в зависимости от того, кем и когда был отправлен отчет.
 
=IF(COUNTIFS($I:$I;C$2;$J:$J;$B3)<>0;"В срок";"")

=ЕСЛИ(СЧЕТЕСЛИМН($I:$I;C$2;$J:$J;$B3)<>0;"В срок";"")
Изменено: БМВ - 26 Май 2018 12:18:52
 
Цитата
БМВ написал:
=IF(СЧЕТЕСЛИМН
Вы хотите запутать автора темы ;) ?
Еще вариант формулой массива:
=ЕСЛИ(C$2=ВПР($B3;ЕСЛИ({1;0};$J$3:$J$7;$I$3:$I$7);2;);"В срок";"")
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
 
Цитата
Bema написал:
Вы хотите запутать автора темы  ?
Ага :-) , забыл как IF переводится, спс что напомнили :-)
 
БМВ, спасибо за ответ. Не знаю почему, но обе Ваши формулы у меня не хотят работать. Пишет «#ИМЯ?».

Bema, спасибо большое. Все работает как надо.
Изменено: Андрей А. - 27 Май 2018 16:22:25
 
Андрей А.,
даже короче =IF(COUNTIFS($I:$I;C$2;$J:$J;$B3);"В срок";"")
 
БМВ, сработало, спасибо!
У меня созрел еще один вопрос. Предположим, мне нужно добавить еще дополнительные условия, при этом нужно сделать так, чтобы правильный критерий был «один из...». Как это сделать?
Страницы: 1
Читают тему (гостей: 1)
Наверх