Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Количество строк с несколькими условиями
 
Добрый день!

Уже несколько дней бьюсь над решением задачи.
Нужно подсчитать кол-во строк, удовлетворяющих условиям.
В принципе, это просто решается с помощью СЧЁТЕСЛИМН, но не в этом случае.

Например, в столбце L может быть несколько условий (взаимоисключающих) - "не согласовано" ИЛИ "требуются уточнения" ИЛИ ""
В столбце H - "Выполнено" ИЛИ "Средний".
И т.д.

По формуле ниже он выдает "0", хотя совпадения есть!
Код
=СЧЁТЕСЛИМН(I11:I13;A3;H11:H13;{"Высокий";"Средний"};J11:J13;"Выполнено";L11:L13;{"не согласовано";"требуются уточнения";""})

Пробовал еще так, но выдает #ЗНАЧ!
Код
=СУММПРОИЗВ(--(I11:I13=A3);--(H11:H13={"Высокий";"Средний"});--(J11:J13={"Выполнено"});--(L11:L13={"не согласовано";"требуются уточнения";""}))

Подскажите, пожалуйста, где косяк?

Спасибо.
 
Цитата
modcom написал:
Подскажите, пожалуйста, где косяк?
Ну хотелось бы пример увидеть.
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
 
Прошу прощения, что не прикрепил пример.
Во вложении выделил нужную ячейку с формулой желтым цветом.
Спасибо.
 
внимательней с текстом "Запланированно" где с двумя "н" где с одним.
Изменено: V - 29 Май 2018 10:27:19
 
запишите все условия отдельно, не объединяя в массив, и все посчитает.
по поводу СЧЁТЕСЛИМН, он не понимает запись {"Высокий";"Средний"} - берет для сравнения только первую запись.
 
Массавная
Код
=SUM(COUNTIFS(I7:I9;A3;H7:H9;{"Высокий";"Средний"};J7:J9;"Выполнено";L7:L9;{"не согласовано"\"требуется уточнения"\""}))

или
=DCOUNT(A6:M9;A6; F2:F3)
+
=AND((I7=$A$3);OR(H7="Высокий";H7="Средний");(J7="Выполнено");OR(L7="не согласовано";L7="требуется уточнения";L7=""))
Изменено: БМВ - 29 Май 2018 18:09:29
 
Цитата
БМВ написал:
Массавная

Спасибо!
Но не очень понятно, как это работает.
Можете пояснить?

У вас в файле такая формула вроде работает:
=СУММ(СЧЁТЕСЛИМН(I7:I9;A3;H7:H9;{"Высокий":"Средний"};J7:J9;"Выполнено";L7:L9;{"не согласовано";"требуется уточнения";""}))

А эта уже не работает:
=СУММ(СЧЁТЕСЛИМН(I7:I9;A3;H7:H9;{"Высокий";"Средний"};J7:J9;"Выполнено";L7:L9;{"не согласовано";"требуется уточнения";""}))

Поясню сразу отличие - между "Высокий" и "Средний" различается знак. Но я не очень понимаю, почему так происходит...
 
modcom,
принцип массивных формул таков что необходимо соблюсти размерность
{"Высокий";"Средний"} -2  не {"согласовано";"требуется уточнения";""} -3 по этому будет ошибка
но нам в любом случае надо перебрать варианты  и это достигается тем, что один из массивов делается не столбцом ,а строкой (другой разделитель как раз это и делает также это возможно через Tranaspose() ). Но такой трюк возможен только если сравниваем два набора, по этому "Выполнено" уже не массив, как был у вас сперва, а единственная константа.
Изменено: БМВ - 4 Июн 2018 12:54:00
 
Цитата
БМВ написал:
принцип массивных формул таков что необходимо соблюсти размерность
Оххх, спасибо вам большое!
Формулы массива - это что-то...
Проще код написать, чем эту формулу выдумывать)
Страницы: 1
Читают тему (гостей: 1)
Наверх