Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Как сортировать одинаковые значения в первом столбце подставляя уникальное значения во втором, MS Excel
 
Подскажите, как построить формулу эксель таким образом, чтобы повторяющиеся значения в первом столбце, во втором столбце имели уникальное значение?
Например:
СчётМесяц
1январь
1февраль
3январь
1март
2январь
3февраль
Спасибо заранее)
Изменено: silentiumsol - 2 Июн 2018 10:28:14
 
И Вам здравствовать! Не понятно что хотите. Покажите в файле, так есть -- так надо.
Изменено: gling - 2 Июн 2018 10:18:53
 
Добрый день!
Спасибо за отклик)

Так есть...

№ счетаМесяц
4451257январь
4415382
4424292
4424293
4424296
4424298
4451297
4415422
4446541
Так надо по каждому  неизвестному в первом столбце

№ счетаМесяц
4451257январь
4451257февраль
4451257март
4451257апрель
4451257май
4451257июнь
4451257июль
4451257август
4451257сентябрь
4451257октябрь
4451257ноябрь
4451257декабрь
 
Цитата
gling написал:
Покажите в файле
Здесь без файла примера можно долго переписываться. Например 4415382 нет напротив названия месяца что дальше? Или тупо для каждого счета сделать 12 строк с месяцами? Как расположить результат? Каждый счет в отдельном столбце или подряд продолжать всё в одном? Что нужно то?  
Изменено: gling - 2 Июн 2018 11:00:03
 
Всю ночь голову ломаю, и ничего путного не получается.
 
А как считать когда дублей (повторов) счетов больше 12? Смотрите 2 варианта. Для отображения месяцев формат ячейки "ММММ".
И третий вариант, не выводит результат если № счета повторяется >12 раз.
Код
=ЕСЛИОШИБКА(--(1&"/"&СЧЁТЕСЛИ($A$2:A2;A2)&"/"&2018);"")

Можно обернуть всё это в ТЕКСТ() и не менять формат ячейки

Код
=ТЕКСТ(--("1/"&СЧЁТЕСЛИ($A$2:A2;A2)&"/2018");"ММММ")

Изменено: gling - 2 Июн 2018 11:50:10 (Заменил файл.)
 
Спасибо) Попробую второй вариант)
Страницы: 1
Читают тему (гостей: 1)