Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Знак "~" мешает работе формулы =ВПР, Как сказать формуле не учитывать этот знак при поиске точного соответствия?
 
Существует система таблиц.
в основной таблице есть формула типа =ВПР, которая смотрит в другие книги. В этих других книгах, есть текстовые данные, которые нужно сравнивать с данными исходной таблицы и забирать определённые значения. Если в ячейке с текстовыми данными среди прочих символов, есть символ "~", который, как я понял, ломает формулу и она не дает результата.

Как научить формулу читать этот знак и воспринимать как текст или игнорировать вовсе?

UPD: или как задать точность соответствия, что бы, например, при условии ИСТИНА в формуле, неточность соответствия варьировалась от 0 до 1 знака.
Изменено: Gortor - 3 Июн 2018 17:22:39
 
Цитата
Gortor написал:
символ "~", который, как я понял, ломает формулу и она не дает результата.
Тильда даёт понять Экселю, что нужно искать не подстановочный знак * илии ?, а конкретно эти символы. Как-то так.
Вот почитайте Использование подстановочных знаков в запросах поиска
Изменено: Bema - 3 Июн 2018 17:45:01
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
 
Bema, благодарю.. с системой поиска разобрался.. Удалять тильду можно будет в два клика, если не придумаем решения более элегантного...

Но вопрос остался не решенным.
Делов в том, что в данных, к которым обращается формула, есть эта тильда.
Данные следующего вида: "Адрес (~70 м. от чего-то)"
И если в таком виде подставить данные в формулу, значения она не выдает. А хочется, что бы выдавало...
Изменено: Gortor - 3 Июн 2018 17:59:11
 
Gortor, покажите пример в файле Эксель. Подумаем...
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
 
Цитата
Gortor написал: Но вопрос остался не решенным.
И будет оставаться таковым, пока вы не усвоите Правила, в т.ч. пп 2.2, 2.3... ;)
Изменено: Z - 3 Июн 2018 18:02:40
"Ctrl+S" - достойное завершение ваших гениальных мыслей!.. ;)
 
Пример с одним адресом...
UPD: прошу прощения за кривость файла..
Изменено: Gortor - 3 Июн 2018 18:16:28
 
Цитата
Z написал:
И будет оставаться таковым, пока вы не усвоите Правила, в т.ч. пп 2.2, 2.3...
Как обычно, инструкцию читаю, когда что-то сломалось... Спасибо=)
П.С. ушел читать правила...
 
Gortor, ну как вариант убирать тильду. Если одной формулой делать, то так можно:
=ИНДЕКС($B$16:$B$25;ПОИСКПОЗ(ПОДСТАВИТЬ(G16;"~";"");ПОДСТАВИТЬ($A$16:$A$25;"~";"");0))
или даже так:
=ИНДЕКС(B16;ЕСЛИ(A16=G16;СТРОКА(A16)-15))
Изменено: Bema - 3 Июн 2018 18:19:25
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
 
Bema, убирал.. Помогало, да..

На счет поиска можно и через Ctrl+F, в строке поиска поставив "~~", найти и заменить на ничего. (Спасибо Вашему первому посту - понял логику тильды в поиске)

Ладно.. Благодарю за помощь с поиском тильды. Будем править ручками и дальше.
 
Цитата
Bema написал:
или даже так:=ИНДЕКС(B16;ЕСЛИ(A16=G16;СТРОКА(A16)-15))
Несколько не понял формулу...
Можете изменить ее под таблицу ниже?
 
Пока все мочат, попробую. Попробовал не получилось.
Изменено: gling - 3 Июн 2018 22:08:51
 
Цитата
gling написал: Пока все мочат
Кого? За что? )
 
Да всего одна буква, а как изменился смысл.) Пора клаву на чистку, через раз печатает, конечно же "моЛчат".
 
В #6 измените формулу так:
Код
=ВПР(ПОДСТАВИТЬ(G16;"~";"~~");A16:B16;2;ЛОЖЬ)
Владимир
Страницы: 1
Читают тему (гостей: 1)