Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Определение скидки по временному интервалу и по бренду, Определение скидки по временному интервалу и по бренду
 
Есть таблица акций (скидок) по временным интервалам и брендам и есть список заказов по брендам. Как определить Скидку по бренду в дату заказа?
 
Madgamer2003,  удалено
Изменено: a.i.mershik - 4 Июн 2018 12:11:06
 
=СУММЕСЛИМН($D$2:$D$8;$A$2:$A$8;H2;$B$2:$B$8;"<="&I2;$C$2:$C$8;">="&I2)

В J2 и протянуть
 
a.i.mershik по вашей формуле у "бренд 7" скидка 30% хотя заказ был сделан 13.05.18, а акция 30% идет с 16.05 по 31.05. Т.е. должно быть 0, а не 30.  
 
Dark1589 спасибо, выручили! Всем, кто заглянул спасибо!
 
Код
=ВПР(H2;$A$2:$D$8;4;0)*(I2>=B2:B8)*(I2<=C2:C8)

формула массива
Изменено: Stics - 4 Июн 2018 12:11:46
 
Код
=СУММПРОИЗВ(($A$2:$A$8=H2)*($B$2:$B$8<=I2)*($C$2:$C$8>=I2)*$D$2:$D$8)
 
как-то так, но что-то было с форматами дат
Страницы: 1
Читают тему (гостей: 1)
Наверх