Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Подсчет количества строк за прошедшую неделю
 
Добрый!
Уважаемые форумчане, прошу помощи...
Есть форма отчета. В ней (выделено цветом) необходимо, чтобы автоматически проставлялось количество заключенных договоров за прошедшую неделю. Как правило, отчет составляется в понедельник. т.е. если сегодня 04.06.2018, то количество заключенных договоров должно быть за 28.05.2018 и до 04.06.2018.
Пробовала связать "<="&СЕГОДНЯ()+7-ДЕНЬНЕД(СЕГОДНЯ();11);B1:Q1;">="&СЕГОДНЯ()-ДЕНЬНЕД(СЕГОДНЯ();11 с счетесли. Ничего не получается. Где-то не там "ковыряю".
Если не в полнедельник составляется отчет, а во вторник(среду), то тоже надо, чтобы за предыдущую неделю подсчитвалось. Возможно функция сегодня() тут и не нужна, раз отчет составляться может и по середине недели
Заранее благодарю
 
=Сегодня()-Деньнед(Сегодня();2) - воскресенье предыдущей недели
=Сегодня()-Деньнед(Сегодня();2)-6 - понедельник пред. недели
Программисты - это люди, решающие проблемы, о существовании которых Вы не подозревали, методами, которых Вы не понимаете!
 
#2
+ знаки сравнения перепутаны.
=SUMIFS(B2:Q2;B1:Q1;">="&TODAY()-6-WEEKDAY(TODAY();11);B1:Q1;"<="&TODAY()-WEEKDAY(TODAY();11))
 
( сумм если вообще ничего не выходит... скорее всего надо "счет" применять, но тут вообще ничего понять не могу( нужна не сумма, а просто количество. не туда сразу "поехала"...
Изменено: supersvetodiod - 4 Июн 2018 18:34:25
 
Цитата
supersvetodiod написал: скорее всего надо "счет" применять
Мо быть угадал... ;)
Код
=СЧЁТЕСЛИМН($F$2:$F$30;">="&СЕГОДНЯ()-7;$F$2:$F$30;"<="&СЕГОДНЯ()-1)
Изменено: Z - 4 Июн 2018 19:00:24
"Ctrl+S" - достойное завершение ваших гениальных мыслей!.. ;)
 
Цитата
Z написал:
Мо быть угадал...
:*  "бодалась" с
=Сегодня()-Деньнед(Сегодня();2) - воскресенье предыдущей недели
=Сегодня()-Деньнед(Сегодня();2)-6 - понедельник пред. недели

Однако, ларчик просто открывался. Спасибо большое! Считает правильно.
 
Еще вариант.
=СУММПРОИЗВ(--('заключ_договоры ФизЛИц 2018 ЦОЭ'!F2:F30>=A3-7))
 
А в этом случае он будет считать за неделю прошедшую, с даты. Т.е. если будет среда, то и подсчет со среды по среду будет?
 
Да.
 
Цитата
AleksSid написал:
Да.
и это тоже нужно в зозяйстве. Возьму на вооружение. Спасибо!)
 
Не обязательно вставлять цитату или копию сообщения для простого ответа!
Пример - Ваше сообщение №10, о чем оно:
Утверждение "Да" очень нужно в хозяйстве! Ваше бездумное цитирование исковеркало смысл.
 
=СЧЁТЕСЛИМН($F$2:$F$30;">="&СЕГОДНЯ()-7;$F$2:$F$30;"<="&СЕГОДНЯ()-1)
Цитата
supersvetodiod написал:
Спасибо большое! Считает правильно.
пока сегоднчя() = понедельник, а когда сегодня() уже стало вторник - уже считает не правильно и будет считать не правильно до след. понедельника!
Изменено: Ігор Гончаренко - 5 Июн 2018 01:50:21
Программисты - это люди, решающие проблемы, о существовании которых Вы не подозревали, методами, которых Вы не понимаете!
Страницы: 1
Читают тему (гостей: 1)