Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Операции в плавающем интервале с условием
 
Добрый день!
Подскажите, можно ли каким то образом в Excel в изменяющихся интервалах просуммировать числа по условию?
Пример:
skv1p1yes11
skv1p1no12
skv1p1yes13
skv1p2no14
skv1p2yes15
skv1p2no16
skv2p1yes17
skv2p1no18
skv2p1yes19
skv2p2no20
skv2p2yes21
skv2p2no22
Необходимо в столбцах просуммировать для каждого набора skv, p  и yes значения в четвертом столбце.
Наборов таких порядка ста тысяч
 
piksel72, файл пример прикрепите. в формате ексель с тем что есть и какой результат получить хотите.
Изменено: a.i.mershik - 5 Июн 2018 15:23:39
 
файл
 
Сводную таблицу постройте по вашим данным и наслаждайтесь.
 
piksel72, поддерживаю...БМВ,
 
БМВ, вариантов, которые необходимо свести очень много.

Если бы в таблице был порядок по skv, p  и yes, допустим, можно было бы поставить условия по смене значения и суммировать одно за другим сбрасывая сумму на смене наборов, но наборы в беспорядке (как минимум yes/no)  
 
=ЕСЛИ(СЧЁТЕСЛИМН(B:B;B3;C:C;C3)=СЧЁТЕСЛИМН($B$1:B3;B3;$C$1:C3;C3);СУММЕСЛИМН(E:E;B:B;B3;C:C;C3;D:D;"yes");"")
=ЕСЛИ(СЧЁТЕСЛИМН(B:B;B3;C:C;C3)=СЧЁТЕСЛИМН($B$1:B3;B3;$C$1:C3;C3);СУММЕСЛИМН(E:E;B:B;B3;C:C;C3;D:D;"no");"")
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
 
piksel72,
Цитата
Если бы в таблице был порядок по skv, p  и yes,

можно так же сделать несколько уровненную сортировку...
Изменено: a.i.mershik - 5 Июн 2018 15:44:54
 
piksel72, посмотрите #5 . я б наверно пласт перенес в строки
 
 
Способ Bema подошёл, спасибо!
Сводная таблица немного не подходит, т.к. в таблице часто значения меняются и если суммы будут в конце каждого интервала, проверять удобнее.
 
=IF((B6<>Таблица1[@Скважина])+(C6<>Таблица1[@Пласт]);SUMIFS(Таблица1[Мощность];Таблица1[Скважина];Таблица1[@Скважина];Таблица1[Пласт];Таблица1[@Пласт];Таблица1[Насыщение];"yes");"")
=IF((B6<>Таблица1[@Скважина])+(C6<>Таблица1[@Пласт]);SUMIFS(Таблица1[Мощность];Таблица1[Скважина];Таблица1[@Скважина];Таблица1[Пласт];Таблица1[@Пласт];Таблица1[Насыщение];"no");"")


Длинннее только из-за обращения к таблицы , если убрать то коротко и ясно.
=IF(($B6<>$B5)+($C6<>$C5);SUMIFS($E$3:$E5;$B$3:$B5;$B5;$C$3:$C5;$C5;$D$3:$D5;"yes");"")
Изменено: БМВ - 5 Июн 2018 17:24:54
Страницы: 1
Читают тему (гостей: 1)
Наверх