Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Применение коэффициента с учетом нескольких условий
 
Доброго всем времени.
Уважаемые, есть рабочая формула, которая содержит аж 4 уровня ЕСЛИ.
Надоело писать километровые формулы.
Подскажите, есть ли альтернатива формулам написанным в оранжевом поле ?
Буду благодарен если подскажите / покажете в какую сторону думать.
Заранее спасибо.
 
kentouklad, название темы Вашей думаю будет не понраву модераторам, лучше предложите новое, не то что формулу переделать а лучше там бы было что эта формула считает, количество бананов в зависимости от массы, стоимость изделя в зависимости от материала, сборки и сроков производства и т.п.
 
=SUMIFS(N:N;L:L;B2;M:M;C2)*D2
только  SUMIFS - наверно у вас СУММЕСЛИМН

ТЕМА - выбор параметра по нескольким условиям
Изменено: БМВ - 5 Июн 2018 16:10:11
 
Тема; "Применение коэффициента с учетом нескольких условий"
Код
=D2*ВПР(B2&C2;$K$1:$N$4;4;0)
Лень двигатель прогресса, доказано!!!
 
a.i.mershik, ну тогда еще вариант формула массива в ячейку F2  и протянуть.
Код
=ИНДЕКС($N$1:$N$4;ПОИСКПОЗ(B2&C2;$L$1:$L$4&$M$1:$M$4;0))*D2
 
вот
 
Модераторам - если название темы действительно не очень - поменяйте плиз на "Применение коэффициента с учетом нескольких условий".
СпасибоСергей, за подсказку с названием темы.
БМВ, Сергей, спасибо за формулы. Обе не работают) / (или в обеих нужно еще и самому подумать)
Изменено: kentouklad - 5 Июн 2018 16:12:37
 
не вникая в данные:
альтернатитва многоуровневой формуле ЕСЛИ - правильная формула, решающая задачу
Программисты - это люди, решающие проблемы, о существовании которых Вы не подозревали, методами, которых Вы не понимаете!
 
Ігор Гончаренко, ёмко и доступно. Именно за этим я и здесь.
 
kentouklad, СТРАННО : но формула  БМВ, работает нормально
Код
=СУММЕСЛИМН($N$1:$N$4;$L$1:$L$4;B2;$M$1:$M$4;C2)*D2

эта так же...

Цитата
a.i.mershik написал:
=ИНДЕКС($N$1:$N$4;ПОИСКПОЗ(B2&C2;$L$1:$L$4&$M$1:$M$4;0))*D2
да и эта

Код
=СУММПРОИЗВ((B2=$L$1:$L$4)*($M$1:$M$4=C2)*$N$1:$N$4)*D2
 
Цитата
kentouklad написал:
Обе не работают
если вы сделали кривой пример то это не значит что решение не рабочее для вашего примера все работает
Лень двигатель прогресса, доказано!!!
 
Цитата
a.i.mershik написал:
но формула   БМВ , работает нормально
подтверждаю. неправильно перевел с английского. после того как автор формулы добавил примечание и немного уронил мою уверенность в знании английского, все работает.
 
Сергей, и вы тоже меня извините )
 
Цитата
kentouklad написал:
немного уронил мою уверенность в знании английского
Не переживайте у меня та же фигня только с Russian, и не только в применении к Excel :-)
 
kentouklad,
и Вы меня извините. прочитал название темы и ответил на поставленный вопрос.
Программисты - это люди, решающие проблемы, о существовании которых Вы не подозревали, методами, которых Вы не понимаете!
Страницы: 1
Читают тему (гостей: 1)
Наверх